FTP issues with OS X Clients

Unanswered Question
Feb 13th, 2008


I have an issue with a particular client that is running a Cisco 871 Router. It does the NAT as well as IDS functions. The problem has been happening is that Mac users cannot get upload speeds faster than about 3.0kb/s to most FTP sites. I can connect and upload just fine with a PC. The Macs can download at normal speed from the same sites, but, not upload. It seems to occur on about half of the FTP sites that they use. I have ruled out the machines as the problem, the ISP says it isn't doing any filtering. The only thing I can think of would be something with the router configuration. I have attached the important parts of the config. If anyone could give me some suggestions I would greatly appreciate it.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Hieu Cao Wed, 02/13/2008 - 17:52

What ftp client software are those MACs using? Fetch? Have you tried different ftp client for them? What OS version are those MAC running? Patch up-to-date?

I don't think there's anything wrong with your config, since you're able to ftp upload/download just fine. About the MAC, I would think that it's more of the application issue than the router config.

Take a look at these links, and try out different ftp client to see if it helps.





gflillich Wed, 02/13/2008 - 22:27


Thanks for your reply. I have tried 3 different FTP clients on both 10.4 and 10.5 systems fully patched: Transmit, Filezilla, and the command line FTP in OSX. All 3 do the same thing. One interesting note when I tried the command line FTP tonight it would transmit about 5-10kb then say stalled for about 30 secs then transmit 5-10kb, stall, etc.

I even took over my Powerbook to the clients office and it did the slowdown on upload then I took it over to another client that has the same ISP, router model/config, and it worked fine.



Paolo Bevilacqua Thu, 02/14/2008 - 03:15

Hi, are you useing pppoe on the FW ?

Does it happen when you connect on vlan1, or the other vlans you have ?

gflillich Thu, 02/14/2008 - 09:26

No PPPOE. It is a burstable T-1 with ethernet hand-off to the Cisco 871.

The clients that I am concerned about and have been testing are on vlan1. I haven't checked the other vlans. I figured they would do the same thing.

Paolo Bevilacqua Thu, 02/14/2008 - 13:54

Hi, on vlan 1 you have "ip tcp adjust-mss 1452" that unless you're using PPPoE somewhere, isn't necessary.

gflillich Thu, 02/14/2008 - 14:39

Thanks, I removed it earlier and that didn't help the problem and put it back it. I think it was part of the initial config that the SDM software puts on.



gflillich Fri, 02/15/2008 - 00:15

Hi hieu,

I don't know that I could force passive versus active because this is the client end I am having problems with. I can connect to and upload to some servers using passive mode, others won't work.

gflillich Fri, 02/15/2008 - 00:18

I found that if I remove the following lines from the config I can upload at normal speeds from the Macs:

ip inspect name SDM_LOW tcp

ip inspect name SDM_LOW ftp

I have to remove both for it to work if I mleave one of the two in it doesn't work.


This Discussion