Mobile Agent log in issues

Unanswered Question

We are in the process of testing out the mobile agent features and I have gone through the documentation and setup everything according to the "Mobile Agent Guide for Cisco Unified CC Enterprise & Hosted". The problem I am running into is that each time I attempt to login via CAD 7.2 I receive the following error:

"Try to log in CTI PORT device for non-mobile agent or invalid CTI PORT for mobile agent. Login denied"

I found the error in the documents but as usual it is not very helpful in how to remedy the situation it just says that basically either the agent you are attempting to login with is not a mobile agent or there is a CTI port issue. Any suggestions would be greatly appreciated.

System Info

IPCC v7.2

CCM v4.1(3)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chad Stachowicz Thu, 07/03/2008 - 08:54

Getting the same thing, anyone got a link to the doc with correct CTI Port configuration for Mobile Agents?

Thanks,

Chad

i ran into the same issue. You have to create two cti ports, (LCPXXXFYYYY and RCPXXXXFYYYY where XXXX is your PG id).

1- Create a CTI port LCP5000F0000.

2- Create a DN of 1234 for the above port.

3- create another CTI port RCP5000F0000.

4-Create a DN of 5678 for the above port.

5- Assign these ports to jtapi user.

- create a device target for DN configured for LCP5000F0000.

i hope this helps...

courtlandholder Tue, 09/30/2008 - 13:05

I am having issues with configuring the device target.

here is what I have, please tell me where I am going wrong.

CTI port LCP5000F0000 - DN of 2405

CTI port RCP5000F0000 - DN of 2450

Device Target - /devtype ciscophone /dn 2405

Label aasociated with CVP 7

The agent is reserved but never gets the call.

Please assist

rbua Wed, 10/01/2008 - 02:48

Hi,

make sure you do not have them configured as Route Points, they need to be just CTI Ports.

That both are associated to the PG JTAPIUser.

If both do, then please check on any codec or calling search space issue that would prevent a media connection.

Regards,

Riccardo

courtlandholder Wed, 10/01/2008 - 12:17

Is this device target in the right format?

/devtype ciscophone /dn 2405

If not, can you provide an example.

Thanks

rbua Wed, 10/01/2008 - 12:29

Yes it is if you are using 4 digits for the agents dialed numbers, please verify your phone model is in the compatibility matrix.

Regards,

Riccardo

courtlandholder Wed, 10/01/2008 - 14:33

I am not sure that I understand your statement about the phone model, please explain.

I am really stuck.

I can login successfully with either nailed or call by call.

When I login with the nailed, my cell phones rings and a connection is made, but I am never connected to the caller although the CAD agent is placed in reserved state.

When I login in call by call mode, again I have a successful login, the CAD agent is placed in reserve state but the cell phone is never called. I verified that by monitoring the gateway.

I am probably going to open a TAC case, but if you recognize this issue, please advise.

Any assistance would be great.

Thanks

Actions

This Discussion