Routing via AUX port

Answered Question
Feb 14th, 2008
User Badges:

I have a dial-up modem connected to my router's AUX port.


Using this setup, I need to get remote users to access our internal servers via dial-up.


The users aren't network admins, so they should not have exec access to the routers. They only need to be able to access the servers on our system, i.e. I need to route their Laptops's traffic via the aux port to the intended server.


Is there a way of configuring the router and modem to do this? Or do I need more equipment in order for this to work?


The router is a 2960 series and the modem is a US Robotics dial up modem.


Any help is greatly appreciated. Thanks!

Correct Answer by pcameron about 9 years 3 months ago

For diarect dial connection, there should not be a lot of difference - the AUX port should run PPP automatically and as long as the PC recognises this it should negotiate and connect.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
paolo bevilacqua Thu, 02/14/2008 - 02:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, configure ppp for the aux and dial-in. Performances won;t be stellar, but it works.

WabukiSensei Thu, 02/14/2008 - 23:11
User Badges:

Hi, thanks for the tip, but I thought you can't configure ppp on AUX ports?

pcameron Mon, 02/18/2008 - 04:50
User Badges:
  • Cisco Employee,

These configs are a bit old and crusty , but they should give you an idea on how to set up async routing on the AUX ports. As Paolo says , performance is not brilliant, but it will work ... The chat scripts would likely need to be modified to suit your particular modems -



#####DIALING SIDE############



username PRIROUTER password SAMEPASSWORDS




chat-script modem "" "atdt\T" TIMEOUT 60 CONNECT \c

chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0" "OK"


!

interface Async1

ip address 192.168.10.2 255.255.255.0

encapsulation ppp

async default routing

async mode interactive

dialer in-band

dialer string 5553731

dialer-group 1

ppp authentication chap

!

ip route 0.0.0.0 0.0.0.0 Async1

!

dialer-list 1 protocol ip permit

!

line aux 0

modem InOut

script reset rstusr

transport input all

flowcontrol hardware

script dialer modem





######RECEIVING SIDE##############



Username RouterA password cisco


!

interface Async1

ip address 192.168.10.1 255.255.255.0

encapsulation ppp

async default routing

async mode dedicated

dialer in-band

dialer-group 1

ppp authentication chap

!

ip route 0.0.0.0 0.0.0.0 async1

!

dialer-list 1 protocol ip permit

!


chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0" "OK"

!

line aux 0

modem InOut

script reset rstusr

transport input all

flowcontrol hardware



WabukiSensei Mon, 04/21/2008 - 20:21
User Badges:

Hi, Thanks for the tip. If I were dialing from a Laptop connected to a modem, would there be any differences in the configuration?


Thanks.

Correct Answer
pcameron Mon, 04/21/2008 - 20:33
User Badges:
  • Cisco Employee,

For diarect dial connection, there should not be a lot of difference - the AUX port should run PPP automatically and as long as the PC recognises this it should negotiate and connect.

WabukiSensei Sun, 05/11/2008 - 19:14
User Badges:

Thanks for the tip, guys. I've finally been able to get this run-down modem to work.

Actions

This Discussion