AddRoute Failed to add route : Code 87

Unanswered Question
Feb 14th, 2008

Hi. I keep getting this error AddRoute Failed to add route : Code 87 when I connect from my home through my Wireless Router to my office. I connect to my Pix 515 and establish the tunnel but cannot access devices on the inside of my network using real vnc. The kicker is that if I go directly from my cable modem or dialed up everything works fine...and sometimes it even works through my router..but only once and awhile. It isn't a PC firewall issue as I have turned this off. It is also not a port forwarding problem with Real VNC and my router...I have also tried that. It seems every time I get the AddRoute Failed to add route : Code 87 error nothing connects. I searched for a good answer and have not found any. It looks like I am not the only one having this problem. Is there something I should check on the Pix 515? The strange thing is that it works just fine when not going through the Belkin Wireless router..I have also tried it on a Linksys and it still doesn't work.


Thanks in advance.

Mike


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
michael.olson Sat, 02/16/2008 - 11:53

I solved the problem.


My Pix needed the following command to do NAT traversal.


isakmp nat-t


I applied this and it worked.



Actions

This Discussion