Routed Access Layer Design Question

Unanswered Question
Feb 14th, 2008
User Badges:
  • Blue, 1500 points or more

The following scenario involves a server farm environment.


Typically, in a switched/L2 access layer design, VLANs are spanned across the routed distribution layer with the use of an L2 crosslink/trunk. HSRP is configured for each VLAN, etc....you know, the 3-Tiered Model.


OK, in a ROUTED access layer design ( a 2-Tiered model) there is no distro layer, just the routed access layer with L3 uplinks to a routed core.


Here is my question:


What if I want to span the VLANs across the ROUTED access layer switches with an L2 crosslink/trunk between them, as is done in a routed distro layer? Theoretically, it should be able to be done. No?


For example, lets say I have ROUTED access switches A1 and A2. A1 and A2 can have routed VLAN interfaces configured for each VLAN, as well as the VLAN's VIP address for HSRP, of course, as well as an L2 trunk between them. In other words, the same as you would configure it in a typical routed distro layer.


Then A1 and A2 will have L3 uplinks to the routed core.


EXAMPLE:


=============================================

SWITCH A1:


vlan 10

name Server_VLAN


interface tengigabitethernet 9/1

description ***Trunk to A2***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 1,10


router eigrp 10

network 10.10.10.0 0.0.0.255


interface vlan 10

ip address 10.10.10.2 255.255.255.252

standby ip 10.10.10.1


=============================================


SWITCH A2:


vlan 10

name Server_VLAN


interface tengigabitethernet 9/1

description ***Trunk to A1***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 10


router eigrp 10

network 10.10.10.0 0.0.0.255


interface vlan 10

ip address 10.10.10.3 255.255.255.252

standby ip 10.10.10.1


=============================================


This will allow me to dual home my server connections on the server VLAN to each of the ROUTED access switches. Correct?


According to Cisco, though, it is said that if a routed access layer is being used, that a VLAN can NOT be spanned across access switches.


From Cisco:


"If there is a business requirement to span a VLAN between [ROUTED] access switches, it is not possible to use a Layer 3 routed access configuration."


Why not?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Fri, 02/15/2008 - 00:28
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi Victor


Because if you cross connect your access-layer switches with a L2 trunk you now have STP in the access-layer which is exactly what a routed access-layer is designed to get around.


In addition, although i may be reading your post incorrectly, your uplinks from the access-layer to the core in a L3 design should not use vlan interfaces as again this extends STP. Your uplinks should be L3 P2P links ie.


int gi0/1

no switchport

ip address x.x.x.x x.x.x.x


As i say i may have misread your post on that last point.


Bear in mind as well that access-layer switches tend to be on different floors so interconnecting these could create a bit of a pigs ears in terms of switch interconnections.


HTH


Jon

Amit Singh Fri, 02/15/2008 - 01:29
User Badges:
  • Cisco Employee,

Hi Victor,


You can certainly make that design and will work for your but it defeats the purpose of a routed access design. As Jon mentioned that routed access design is typically used to overcome the STP based layer-2 design and the issues related to it. If you are setting up the design mentioned above you are eventually falling back to a 2 Tier STP design. In this case, your all the traffic for a particular vlan will still travel across the active VLAN HSRP switch and will again get you the STP based timers issues.


Some of the salient points about the routed access design are:


1. Improved convergence


2. Dynamic traffic load-balancing


3. Simplified multicast configuration


Please see the the most important point of the routed access design is the convergence from traditional L2- based STP design and it gives more than 5X convergence time over the STP design.


HTH,

-amit singh

lamav Fri, 02/15/2008 - 09:25
User Badges:
  • Blue, 1500 points or more

Jon and Amit:


Thank you very much for those detailed answers. I really appreciate the time you took to write them.


My concern was that, from the way the Cisco document worded it, I thought perhaps there was some technical restriction that made the scenario I gave above an impossibility. I thought that my knowledge base regarding this particular issue was missing an important piece and was not allowing me to understand why a trunk "cannot" (should not, actually) exist between two access switches in a routed access layer.


But I see now that the concern involves minimizing the switched domain, which of course is the main purpose of deploying a routed access layer.


Jon, with reragrd to your uplink concern, you are right, you misread my post. :-) The VLAN interface I show in my example config above is for the server VLANs, not the uplinks. I would not create an SVI for a VLAN and place an L2 port in that VLAN to create a routed connection. That is the way we were forced to do it in the days of CatOS. But with Native IOS, I would create a physical L3 routed connection and be done with it.


Now, one other thing, though....


Having concluded that one should not span the VLAN across access switches, is it fair to say that a routed access layer is not recommended for a server farm, since it would make dual-homing the servers to achieve switch diversity for HA an impossibility?

Edison Ortiz Fri, 02/15/2008 - 09:32
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

> is it fair to say that a routed access layer is not recommended for a server farm,

> since it would make dual-homing the servers to achieve switch diversity

> for HA an impossibility?


Is clicking now, huh? :)



lamav Fri, 02/15/2008 - 09:43
User Badges:
  • Blue, 1500 points or more

Edison, Edison, Edison...why must thou always be so sarcastic with me? :-(



Edison Ortiz Fri, 02/15/2008 - 11:39
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I only do that with people I like. I actually interviewed you for a position at 136 Madison over a year ago.

lamav Fri, 02/15/2008 - 12:15
User Badges:
  • Blue, 1500 points or more

LOLOL...I KNEW your name sounded familiar! The publishing consortium???

Edison Ortiz Fri, 02/15/2008 - 12:49
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

IPG, yeah.

Actions

This Discussion