1700 Router Configuration DLCI

Unanswered Question
Feb 14th, 2008

I have a cisco 1751 router with interfaces Ethernet0/0 and FastEthernet0/0.

My ISP is asking me to configure the router with DLCI 16 with IP X.X.X.Xa -Gateway X.X.X.Xb and DLCI 17 with IP Y.Y.Y.Yc - Gateway Y.Y.Y.Yd


How do I configure this?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
avilt Thu, 02/14/2008 - 18:20

Could you pls list the commands, do I need to define encapsulation as frame-relay on subinterfaces?

vaisharm Thu, 02/14/2008 - 20:54

As pointed out by Mohamed, you would need a serial interface/module for frame relay. Here's how you can configure it:


!

interface Serial1/1

no ip address

encapsulation frame-relay

no shutdown

!

interface Serial1/1.16 multipoint << If using multipoint sub-if

ip add X.X.X.Xa

frame-relay map ip X.X.X.Xb 16 broadcast << If using multipoint sub-if

no shutdown

!


OR


interface Serial1/1.16 point-to-point << If using point-to-point sub-if

ip add X.X.X.Xa

frame-relay interface-dlci 16 << If using pont-to-point sub-if (No need to specify the gateway)

no shutdown

!


Same way create an additional sub-interface (Serial1/1.17) for Y.Y.Y.Yc (DLCI 17).


-Vaibhav

avilt Thu, 02/14/2008 - 21:49

Thank You Vaibhav.

Is it not possible to define the DLCI on ethernet interface by creating suninterfaces or by something else.

My ISP has given me some details and from their side its a LAN cable which has to be connected to our router (no serail cable). All they have given is WAN IP's and DLCI id. I couldnot find the option to enable DLCI on Ehternet interface even by defining subinterfaces.

avilt Thu, 02/14/2008 - 23:01

Sorry, It has to be terminated on BRI interface. I have BRI0 interface. How do I define subinterfaces on BRI0. I need 2 subinterfaces. I am getting the below error.


TEST(config)#interface BRI0

TEST(config-if)#no ip address

TEST(config-if)#encapsulation frame-relay ietf

TEST(config-if)#frame-relay lmi-type q933a

TEST(config)#interface BRI0:1

% Cannot access B-channel interfaces

vaisharm Fri, 02/15/2008 - 01:45

BRI is normally used as a backup for the frame-relay link. You'll have to have a serial interface for frame-relay to be able to configure IP to DLCI mappings.


-Vaibhav

avilt Sat, 02/16/2008 - 02:02

I am able to configure as below. Is it going to work? I cannpt have serial interface as the ISP side has given me LAN (RJ45) type connection

---------------------------------------------

interface BRI0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a

!

interface BRI0.16 point-to-point

ip address x.x.x.x 255.255.255.0

no arp frame-relay

frame-relay interface-dlci 16


Richard Burts Sat, 02/16/2008 - 08:18

avil


I do not believe that this will work. The BRI interface expects to talk to an ISDN switch but there is no ISDN switch configuration in what you have posted.


I would like to know more about this ISP connection. You tell us that it is an LAN(RJ45) type connection. What kind of device is it that is giving the connection?


There are quite a number of serial cards with built in CSU/DSU which have connection via RJ45 cable. I suspect that this is what the ISP wants you to use. Especially when a DLCI is part of what they specify it means Frame Relay. And Frame Relay needs a serial connection.


HTH


Rick

Paolo Bevilacqua Sat, 02/16/2008 - 09:02

Hi,


As strange it may seem, frame-realy can be used on ISDN BRI.


However, i think the rj45 that avil has been given, is either a t1 or e1 connector. Avil, can you clarify with you service provider, which service have your purchased ?

Richard Burts Sat, 02/16/2008 - 09:19

Paolo


To run Frame Relay over BRI do you not still need the isdn switch-type and other ISDN configuration?


HTH


Rick

Paolo Bevilacqua Sat, 02/16/2008 - 09:27

Yes you do. It was something used in the past to provide back-up with frame-relay services, terminating into devices incapable of routing. I haven't heard on anyone using it for real, but the feature is there.


Also, in Germany, they used isdn bri as replacement for low speed leased lines, that's called nailed bri.


avilt Thu, 02/21/2008 - 22:58

My ISDN leased line is up with the below config.


isdn switch-type ABC

isdn leased-line BRI1/0


interface BRI1/0:1

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a


interface BRI1/0:1.16 point-to-point

ip address x.x.x.y 255.255.255.0

ip ospf network non-broadcast

ip ospf cost 10

ip ospf priority 0

no arp frame-relay

no cdp enable

frame-relay interface-dlci 16 IETF

!

interface BRI1/0:1.17 point-to-point

ip address y.y.y.z 255.255.255.0

ip ospf network non-broadcast

ip ospf cost 20

ip ospf priority 0

no cdp enable

frame-relay interface-dlci 17 IETF

Actions

This Discussion