cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
691
Views
0
Helpful
6
Replies

Routing and Redundancy Case

habeeb_talal
Level 1
Level 1

Hi,

We have two links between HQ and our Branch, one is active and the second is standby and there is HSRP between the two routers connected to both links.

We want to distribute the traffic between the two links, so we decide to route some services to the standby link and in the same time if the link is down in one of the links the traffic should route to the up and running link.

These are the configuration of both routers and I'll write the problem that we faced after reading the configuration:

1- Active Router:

interface GigabitEthernet0/0

ip address 172.16.101.7 255.255.255.0

duplex auto

speed auto

standby 102 ip 172.16.101.5

standby 102 priority 200

standby 102 preempt

standby 102 track Serial0/0/0 70

!

interface Serial0/0/0

bandwidth 512

ip address 11.11.11.1 255.255.255.0

encapsulation ppp

!

ip route 10.0.0.0 255.255.0.0 11.11.11.2

ip route 10.0.55.13 255.255.255.255 172.16.101.6

ip route 10.0.55.13 255.255.255.255 11.11.11.2 2

ip route 10.0.55.16 255.255.255.255 172.16.101.6

ip route 10.0.55.16 255.255.255.255 11.11.11.2 2

=========================================

2- Standby Router

interface Tunnel1

ip address 172.16.209.1 255.255.255.252

keepalive 10 3

tunnel source 10.12.55.14

tunnel destination 172.16.199.2

!

interface GigabitEthernet0/0

ip address 172.16.101.6 255.255.255.0

duplex auto

speed auto

standby 102 ip 172.16.101.5

standby 102 timers 120 121

standby 102 priority 150

standby 102 preempt

!

interface GigabitEthernet0/1

bandwidth 512

ip address 10.12.55.14 255.255.255.252

duplex auto

speed auto

!

ip route 10.0.0.0 255.255.0.0 Tunnel1

======================================

There are two IP addresses 10.0.55.13 and 10.0.55.16, in the active router we made two routes for each IP address, the first is to the standby router and the second is to the serial interface in the active router and this last route is with administrative distance 2.

The HSRP is configured between the interface GigabitEthernet0/0 in both routers.

This configuration is not working when the GigabitEthernet0/0 or when the tunnel is down.

So what is the best solution to distribute the traffic using the previous scenario and in the same time if the interfaces are down or the link or tunnel is down the traffic will route to the only working router?

Thanks

1 Accepted Solution

Accepted Solutions

You need to configure something like this on the primary router

Check whether your IOS supports it

ip sla monitor 1

type echo protocol ipIcmpEcho --- this shud be your other end tunnel IP

timeout 1000

frequency 3

threshold 2

ip sla monitor schedule 1 life forever start-time now

track 123 rtr 1 reachability

ip route track 123

This will make sure the route is in the RT only when the tunnel is up

http://cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html#wp1071672

HTH

Narayan

View solution in original post

6 Replies 6

royalblues
Level 10
Level 10

In your case when the tunnel goes down on the standby router, HSRP woud failover but due to the dual static routes, these are sent to the standby router and get blackholed.

Though, enhanced object tracking with both HSRP and static routes can solve your problem, i would suugest configuring GLBP

Have a look here

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fb97.html

HTH

Narayan

Hi,

Thanks Narayan for your suggestion, i found it very useful for my case, but is there any other way to solve this issue without changing to GLBP, you mention enhanced object tracking and etc?

Thanks

You need to configure something like this on the primary router

Check whether your IOS supports it

ip sla monitor 1

type echo protocol ipIcmpEcho --- this shud be your other end tunnel IP

timeout 1000

frequency 3

threshold 2

ip sla monitor schedule 1 life forever start-time now

track 123 rtr 1 reachability

ip route track 123

This will make sure the route is in the RT only when the tunnel is up

http://cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html#wp1071672

HTH

Narayan

Amit Singh
Cisco Employee
Cisco Employee

What is the " show standby " output currently from your both the routers.

What happens when your interface is down on the primary router? Do you have some capture of the " show standby " when your interface is down. I have noticed one thing and this is the timers mismatch between the Primary and the secondry router interfaces. Why is that so ? Please change the timers to be exact the same vlaue on both the routers. It is suggested not to change the HSRP timers untill and unless there is some requirement and has to be same across the routers.

HTH,

-amit singh

Hi,

Thank you amit, this is the show standby output:

=======================

Primary router:

GigabitEthernet0/0 - Group 102

State is Active

28 state changes, last state change 4d18h

Virtual IP address is 172.16.101.5

Active virtual MAC address is 0000.0c07.ac66

Local virtual MAC address is 0000.0c07.ac66 (v1 default)

Hello time 120 sec, hold time 121 sec

Next hello sent in 95.484 secs

Preemption enabled

Active router is local

Standby router is 172.16.101.6, priority 150 (expires in 65.904 sec)

Priority 200 (configured 200)

Track interface Serial0/0/0 state Up decrement 70

IP redundancy name is "hsrp-Gi0/0-102" (default)

================

Secondary Router

GigabitEthernet0/0 - Group 102

State is Standby

1 state change, last state change 2d21h

Virtual IP address is 172.16.101.5

Active virtual MAC address is 0000.0c07.ac66

Local virtual MAC address is 0000.0c07.ac66 (v1 default)

Hello time 120 sec, hold time 121 sec

Next hello sent in 107.292 secs

Preemption enabled

Active router is 172.16.101.7, priority 200 (expires in 18.868 sec)

Standby router is local

Priority 150 (configured 150)

IP redundancy name is "hsrp-Gi0/0-102" (default)

both routers have the same timers.

Narayan, your solution solve my problem so i would like to thank you for that, but i'm interested to know if there is any other solution without using object tracking?

Thanks

Glad to hear that the problem got solved..

Unfortunately i do not see any other way of implemeting this within your network topology

Narayan

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card