explanation of ADSL configuration please

Answered Question

Hi All

I was thinking of picking up a Cisco 877W router to act as my wireless modem/router. However my ISP will not support Cisco though they have provided a basic configuration to get the ADSL up and running.

I am not sure I understand the configuration and was wondering if someone would be kind enough to explain the parts marked in red in the attached configuration.

I am not sure that I understand why the ATM0 interface has no IP address assigned but the Eth 0 interface does and how they tie together.

Also I assume that I need to create a VLAN for my inside IP addresses (192.168.x.x) and configure NAT, a DHCP server and appropriate ACL's?

If anybody could provide a complete (ADSL, NAT & DHCP) example config, it would be much appreciated.

Extra Information: Currently my public IP is dynamically assigned though in the near future I hope to switch to having a static IP address assigned.

Best Regards & TIA,

Michael

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 8 years 9 months ago

> In the portion of configuration below, which also came from my ISP and I am told is for use with a static

> IP address(es), it appears that the static IP address (or one from a range) is assigned to Interface Vlan1.

> Is this correct?

You can assign the IP address to interface Vlan1 or to interface dialer1. If you assign to interface Vlan1, you can assign other public IP addresses to devices connected to FastEthernet0 thru FastEthernet3 since they also belong to Vlan1. If you assign the IP address to dialer1, you can only use that IP address on that interface (like a point-to-point connection).

The unnumbered command will clone the IP address from Vlan1 in Dialer1.

> If I then wanted to have the router assign private IP addresses to my inside clients.

> I would do the following, ......

Correct.

> If an ISP provided a number of public IP addresses (say a /29 subnet),

> is it possible to configure a NAT pool and have these 6 IP addresses perform overloading?

Yes, you can also assign static IP address to devices connected in FasEthernet0 thru 3 as I explained above.

Correct Answer by Edison Ortiz about 8 years 9 months ago

Michael,

Please see this link:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a729.shtml

You will need ip address negotiated under dialer1 if you are using dynamic IP address from the provider.

HTH,

__

Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.

Hi Edison

Cheers for the quick response and the link. It was very helpful and also provided another link to a page with step by step troubleshooting, which is very helpful.

Can I ask a couple more questions please,

In the portion of configuration below, which also came from my ISP and I am told is for use with a static IP address(es), it appears that the static IP address (or one from a range) is assigned to Interface Vlan1.

Is this correct?

And the line "ip unnumbered Vlan1" under the Dialer1 interface is tying the Dialer1 interface to the static IP address.

Is this correct?

If I then wanted to have the router assign private IP addresses to my inside clients. I would do the following,

1. Create VLAN2

2. Assign some/all of the Fast Ethernet ports to VLAN2.

3. Create interface VLAN2 and assign an IP address in the private range to this interface (say 192.168.1.1).

4. Configure a DHCP Pool for this range, excluding the IP address assigned to the interface.

5. Configure interface VLAN2 as my "nat inside" interface and interface Dialer1 as my "nat outside interface

Is this correct?

Last Question (for now at least :) )

If an ISP provided a number of public IP addresses (say a /29 subnet), is it possible to configure a NAT pool and have these 6 IP addresses perform overloading?

Thank you for your time and patience,

Best Regards,

Michael

+++++ Configuration Extract from which prompted questions above ++++++

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Virtual-Dot11Radio1

no ip address

!

interface Vlan1

ip address XXXXXX 255.255.255.252 ! PUBLIC ADDRESS FOR LINE

ip tcp adjust-mss 1400

!

interface Dialer1

ip unnumbered Vlan1

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1400

dialer pool 1

dialer remote-name redback

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname eircom

ppp chap password 7 141500040D00282A2A2C62

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

++++++ End of Configuration Extract ++++++

Correct Answer
Edison Ortiz Sat, 02/16/2008 - 08:04

> In the portion of configuration below, which also came from my ISP and I am told is for use with a static

> IP address(es), it appears that the static IP address (or one from a range) is assigned to Interface Vlan1.

> Is this correct?

You can assign the IP address to interface Vlan1 or to interface dialer1. If you assign to interface Vlan1, you can assign other public IP addresses to devices connected to FastEthernet0 thru FastEthernet3 since they also belong to Vlan1. If you assign the IP address to dialer1, you can only use that IP address on that interface (like a point-to-point connection).

The unnumbered command will clone the IP address from Vlan1 in Dialer1.

> If I then wanted to have the router assign private IP addresses to my inside clients.

> I would do the following, ......

Correct.

> If an ISP provided a number of public IP addresses (say a /29 subnet),

> is it possible to configure a NAT pool and have these 6 IP addresses perform overloading?

Yes, you can also assign static IP address to devices connected in FasEthernet0 thru 3 as I explained above.

Actions

This Discussion