How to configure the BRI 0/1/0 on cisco 1841

Unanswered Question
Feb 17th, 2008

I've never worked with ISDN BRI all my life. Can anyone help me to configure an ISDN BRI interface on a cisco 1841? Please give me some ideas? I've been reading ISDN BRIs but I need bit of explanation.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (6 ratings)
Loading.
spremkumar Mon, 02/18/2008 - 19:52

hi

what kinda scenario you are looking out for ?

is it normal dial out or dial in scenario ?

regds

bericaleb Thu, 02/21/2008 - 18:37

hi

I have my primary link on a Telecom LL, the secondary will be the ISDN link. This two links are between headoffice and the branch office.

shivlu jain Tue, 02/19/2008 - 01:25

interface BRI0X/Y

ip address 192.X.x.X 255.255.255.xx

encapsulation ppp

dialer idle-timeout 1000

dialer string

dialer load-threshold 32 either

isdn switch-type basic-net3

isdn point-to-point-setup

ip route 0.0.0.0 0.0.0.0 brix/y

regards

shivlu

Goutam Sanyal Tue, 02/19/2008 - 22:05

Hi Shiv,

Can u please clarify me why the dialer idle-timeout sets to 1000? :)

If it is a private network with PRI/BRI then u can go for the following:

!

!

interface Multilink1 (optional/if configured)

bandwidth 64

ip address xx.xxx.xx.xx 255.255.255.252

no ip redirects

no ip proxy-arp

max-reserved-bandwidth 90

service-policy output ABC (If the policy sets/optional)

!

!

interface Serial0/0

bandwidth 64

no ip address

encapsulation ppp

backup delay 0 60 (sets the min and max timing for dialing ISDN)

backup interface Dialer1 (sets the backup dialer interface)

no fair-queue

ppp multilink

ppp multilink group 1 (bonding with Multilink1 )

!

!

interface BRI1/0

no ip address

encapsulation ppp

dialer pool-member 1 max-link 1

isdn switch-type basic-net3

!

!

!

interface Dialer1

ip address xx.xxx.xxx.xx 255.255.255.0

no ip redirects

no ip proxy-arp

encapsulation ppp

dialer pool 1

dialer string (Far end PRI or BRI no)

dialer string (Far end PRI or BRI no)

dialer string (Far end PRI or BRI no)

dialer-group 1 (sets the interesting traffic to bring the interface as backup)

ppp authentication chap

crypto map XYZ (if crypro configure/ optional)

!

!

access-list 150 permit esp any any (if required for ur network)

access-list 150 permit udp any eq isakmp any eq isakmp (permit the isakmp traffic/ optional/ if required ur network)

access-list 150 permit ip any host xx.x.xxx.xxx

access-list 150 permit ip any xxx.x.xx.0 0.0.0.255

dialer-list 1 protocol ip list 150

!

It may depend on the Network structures, as well as your as per your requirement.It's based upon Primary link as LC and backup as ISDN, where the site office will dial to CO, if primary failed.

If any clarification, pls post your query.

Thanks

Goutam

Please rate if its helps u!!!

bericaleb Tue, 02/26/2008 - 23:48

Hi Shiv & Goutam

the configurations, you provided doesn't seem to bring the link up. Please see attached the configurations for these two sites. Pls identify where my fault is?

Goutam Sanyal Wed, 02/27/2008 - 00:21

Hi,

1. You have configured the dialer group, but not the interesting Traffic, with the interface dialer1.

2. Primary Interface (Serial) is not configured with the backup interface (bri)

3. For the second router the dialer interface is not configured.

4. Also you have to mention the static route for end-to-end connection.

5. Site B, BRI is configured with IP address, where as SITE A is not configured.

6. Site B, is not configured with Dialer Interface.

The bellow are missing

A. Backup delay 0 60 (sets the min and max timing for dialing ISDN)

B. Backup interface Dialer1 (sets the backup dialer interface)

C. ACL

If required, do contact

Goutam

Pls rate if it helps u!!!

bericaleb Wed, 03/26/2008 - 21:14

Hi Goutam

thanks for your help, I think we're getting there. Regarding the above,

The bellow are missing, please clarify where I should configure, is it on the BRI interface or the serial interface?

A. Backup delay 0 60 (sets the min and max timing for dialing ISDN)

B. Backup interface Dialer1 (sets the backup dialer interface)

C. ACL

Goutam Sanyal Wed, 03/26/2008 - 23:15

Hi Bernadette,

A. “Backup delay 0 60”, argument is used under interface configuration mode, where this argument ask for the backup/secondary interface (BRI in your case) to turn on imm (0 sec) and will remain till 60 sec after the primary interface restoration. As per Cisco the argument sets a 60-second delay on deactivating the secondary line (serial interface); however, the line is activated immediately. In your case that argument is missing under your primary interface configuration. (Need to configure under serial/primary interface)

B. “backup interface dialer 1”, argument is used under interface configuration mode, Backup Interface - This is an interface that stays in standby until the primary interface line protocol is detected as down and then is brought up. (Need to configure under serial/primary interface)

C. ACL, to specify the interesting traffic with your backup interface.

example:

access-list 150 permit ip any host XX.X.XXX.X

access-list 150 permit ip any XXX.X.X.X YYY.YYY.YYY.YYY

dialer-list 1 protocol ip list 150

Now you need to build this ACL (as the interesting traffic for your network) under dialer interface (interface dialer 1, in your case)

As per the post this are missing.

For more details you can visit the following:

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a0080093c2e.shtml

http://www.cisco.com/en/US/tech/tk801/tk379/technologies_configuration_example09186a008010456b.shtml

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009457d.shtml

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a0080087225.html

Thanks

Goutam

Please rate if I am informative!!!

bericaleb Thu, 03/27/2008 - 17:00

HI Goutam

I've rated your helpful tips.

I've done the configurations as per your advise here, but only on one router, that is the Site A router. Do I do configurations on both routers? The ACL bit is confusing me, what does the XX and YY addresses stand for in my case? And will I configure ACLs on both routers?

Goutam Sanyal Thu, 03/27/2008 - 22:35

Dear Bernadette,

You can configure the ISDN-BRI (Dialer Interface) as a backup to a single side of your router or you can go for the requirement as per your network infrastructures. If I shear my experience, then I'd like to suggest you to configure the same (Dialer Interface) to the both side of the Router as backup.

I'd like to address your next issue, which is ACL. By the ACL you can configure the interesting traffic for your network. Interesting Traffic means, assumed that Site_A_Router is connected with Site_B_Router with the backup link (ISDN BRI) and the users of LAN segment, which is connected with Site_B_Router wants to communicate with your database,applications etc. etc., which is located at LAN segment of Site_A_Router. Now the ACL will help you to build the interesting traffic as per your requirement. Where I address "XX" as the IP Address/network Address and "YY" is the subnet musk or Wild Card.

Revert if you have any query!!!

Thanks for using the rating system. Expecting the same if its help you!!!

Goutam

bericaleb Fri, 03/28/2008 - 00:08

Hi Goutam,

I've rated your post.

Is the ACL a requirement for my case?

What is normally the interface status of the BRI interface if it is not being used?

Goutam Sanyal Fri, 03/28/2008 - 00:25

Hi Bernadette,

When you are configuring DDR, then suggesting you to use ACL, the dialer interface will dial the ISDN Number when it will recognize the Interesting Traffic on the Network, else it will remain active.

The BRI interface will up in normal status, i.e. BRI0/0/0 is up, line protocol is up (spoofing)

Thanks for using the rating system hope u will follow it again!!!

Goutam

bericaleb Sun, 03/30/2008 - 19:47

Hi Goutam

thanks again for this informative response. I have attached here a clean copy of the configs of both sites again. Pls have a look and point out what I'm missing.

THe BRI interfaces are showing for Site A Up and down and down and down for Site B. What could be missing out. THis is really getting on my nerves, as I've done all that is suggested, but status seem to be the same. pls assist me as soon as possible as my manager seem to be putting alot of pressure on me to get this working.

bericaleb Thu, 02/21/2008 - 18:43

Hi shivlu

pls explain why the bit on dialer idle-timeout 1000, What is this 1000? What is the dialer string? Do I have this type of info on both end of the link.

I don't understand the ip route 0.0.0.0 0.0.0.0 brix/y Becuase currently, I have a route already on our router for internet traffic.

alvin_acar Thu, 02/21/2008 - 21:52

Hi Bericaleb,

The 1000 on the dialer idle-timeout command means that the ISDN connection will disconnect after 1000seconds of no traffic. The traffic is defined as an interesting traffic which is the "dialer-list" command. The ip route means that all routes will go to the BRI interface when the route preference is reached.

Hope this helps

bericaleb Tue, 03/11/2008 - 22:07

Hi

regarding the ip route 0.0.0.0 0.0.0.0 pointing to another devices on the network. If I put in the route you suggested will it not have any impact on the route I have here. Please also explain what a route preferene is and what it does, and give me an example.

Goutam Sanyal Tue, 03/11/2008 - 22:17

Hi,

When it is not working, you can try to put a static route with the IP Address of next dialing router and a highest AD of your configured Routing Protocol.

Thanks

Goutam

pls rate if it works!!!

Goutam Sanyal Thu, 02/21/2008 - 22:21

Hi,

As per Cisco:

The dialer idle-timeout interface configuration command specifies the duration of time before an idle connection is disconnected. Previously, both inbound and outbound traffic would reset the dialer idle timer. The Dialer Idle Timer Inbound Traffic Configuration feature enables you to specify that only inbound traffic will reset the dialer idle timer.

(Where 1000 is in Seconds, but going for high value of sec can increase your ISDN Bill.)

Benefits:

By specifying that only inbound traffic will reset the dialer idle timer, you can prevent unexpected Internet traffic from keeping an idle connection from being disconnected.

Restrictions.You cannot specify that only outbound traffic will reset the dialer idle timer.

dialer string:

To specify the string (ISDN Telephone [PRI/BRI] number) to be called for interfaces calling a single site, use the dialer string command in interface configuration mode.

ip route 0.0.0.0 0.0.0.0 brix/y:

ip route 0.0.0.0 0.0.0.0 xx.xxx.xxx.x AD/BRI Interface (x/y) (Where xx.xxx.xxx.x is the next hop address and as per my opinion set the AD with the value of 250 / to route the traffic with the BRI interface x/y only)

Explanation:

Where it puts the traffic with the default route of 0.0.0.0 0.0.0.0 with the next hop address as xx.xxx.xxx.x and the AD (Administrative Distance), which you have to set max of your running routing protocol. Either the traffic will follow that route only. OR, you can go for the BRI Interface x/y, where your traffic will pass through the specified Interface only.

Hope it does clarify you; hence you can post your query also.

Thanks

Goutam

Pls rate if it helps u!!!

bericaleb Wed, 03/26/2008 - 21:21

Goutam,

I have a default route 0.0.0.0 0.0.0.0 to an ip on the network for internet traffic, what implications will this bring about to this route if I enter what you've suggested above?

Actions

This Discussion