cme: line selection failed

Unanswered Question
Feb 17th, 2008

we have a ccme with 4 analog lines (centrex) to phone co.

calling and receiving from voip phones are fine. But when user pick a line (phones shared lines and multi lines was configured for each phone) and call was made, ccme used different line number to make a call.

How can we make a call from a line which was picked.

Thanks,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rob.huffman Sun, 02/17/2008 - 17:58

Hi SR,

Have you looked into using this good CME Feature?

Automatic Line Selection for Incoming and Outgoing Calls

On multiline IP phones, lifting the handset automatically selects the first ringing line on the phone or, if no line is ringing, selects the first available idle line for outgoing calls. This is the default behavior for all multiline IP phones.

Under some circumstances, however, you might want to require that a line button be explicitly pressed to select an outgoing line or to answer an incoming call. In Cisco CME 3.0 and later, you have the flexibility to assign the type of line selection that each IP phone uses.

The Automatic Line Selection feature allows you to specify, on a per-phone basis, the line that is selected when you pick up a phone handset.

Any of the following behaviors can be assigned on a per-phone basis:

Automatic line selection-Picking up the handset answers the first ringing line or, if no line is ringing, selects the first idle line. Use the auto-line command with no keyword or argument. This is the default.

Manual line selection (no automatic line selection)-Pressing the Answer soft key answers the first ringing line, and pressing a line button selects a line for an outgoing call. Picking up the handset does not answer calls or provide dial tone. Use the no auto-line command.

Automatic line selection for incoming calls only-Picking up the handset answers the first ringing line, but if no line is ringing, it does not select an idle line for an outgoing call. Pressing a line button selects a line for an outgoing call. Use the auto-line incoming command.

Automatic line selection for outgoing calls only-Picking up the handset for an outgoing call selects the line associated with the button-number argument. If a button number is specified and the line associated with that button is unavailable (because it is a shared line in use on another phone), no dial tone is heard when the handset is lifted. You must press an available line button to make an outgoing call. Incoming calls must be answered by pressing the Answer soft key or pressing a ringing line button. Use the auto-line command with the button-number argument.

Automatic line selection for incoming and outgoing calls-Pressing the Answer soft key or picking up the handset answers an incoming call on the line associated with the specified button. Picking up the handset for outgoing calls selects the line associated with the specified button. Use the auto-line command with the button-number argument and answer-incoming keyword.

From this good CME doc;

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeautol.html

Hope this helps!

Rob

smallrain_2 Sun, 02/17/2008 - 18:50

Hi Rob,

I read your in other thead and tried it but didn't work.

On phone side, it is not a problem. But router/ccme is using random lines.

Any idea?

Here is my conig:

voice-port 0/1/0

connection plar 1111

caller-id enable

!

voice-port 0/1/1

connection plar 1112

caller-id enable

!

dial-peer voice 11 pots

description EXTERNAL DIAL PEER FOR 1111

destination-pattern 9.T

no digit-strip

direct-inward-dial

port 0/1/0

!

dial-peer voice 12 pots

description EXTERNAL DIAL PEER FOR 1112

destination-pattern 9.T

no digit-strip

direct-inward-dial

port 0/1/1

ephone-dn 1 dual-line

number 1111

!

ephone-dn 2 dual-line

number 1112

ephone 1

device-security-mode none

mac-address 001B.xxxx.xxx1

type 7931

auto-line incoming

button 1:1 2:2

!

ephone 2

device-security-mode none

mac-address 001B.xxxx.xxx2

type 7931

button 1:1 2:2

Thanks,

Paolo Bevilacqua Mon, 02/18/2008 - 02:42

Hi,

which number is being used ? It has to be either 1111 or 1112 depending which line was used.

dmitrybarsky Mon, 02/18/2008 - 07:05

Try adding "preference" to your outgoing dial peers. So, in the second outgoing dial peer add "preference 1" (leave the first one alone since preference 0 is the default, I believe.

Thanks,

~barsky

smallrain_2 Mon, 02/18/2008 - 07:58

I have tried all I can think of, including preference. Call go out consistantly from lowest prefernce dial-peers if preference value was assigned.

That is not what I want. I want to pick a line and call out from that particular line.

Thanks,

smallrain_2 Mon, 02/18/2008 - 08:01

I was testing from ephone 1, which is configured with "auto-line incoming"; calls randomly go out from both. (actually from 4 different lines; I was too lazy to show/copy entire config)

Thanks,

Paolo Bevilacqua Mon, 02/18/2008 - 09:52

Hiw, can you post the relevant config, end explain exactly what is happening ? When you push a button before calling, you should never be able to come out with a different number.

Also please mention exact IOS used and phonw firmware.

smallrain_2 Mon, 02/18/2008 - 11:45

Here are phone loads and IOS info:

tftp-server p00403020214.bin

tftp-server flash:P00308000400.bin

tftp-server flash:P00308000400.loads

tftp-server flash:P00308000400.sb2

tftp-server flash:P00308000400.sbn

telephony-service

load 7931 P00308000400

max-ephones 30

max-dn 30

timeouts interdigit 3

dn-webedit

time-webedit

transfer-system full-consult

"flash:c2800nm-advipservicesk9-mz.124-15.T3.bin"

The dial-peers and voice-ports config are already posted in the previous messages.

And here is what happen:

1. line number are successfully configured on the phone

2. picking each line give a proper dial-tone

3. calling out is not a problem and all calls went through

4. only problem was router/ccme was using randon line to call out. In other words, when line 1 was picked on the phone and outbound calls was made, router used either line 1 or other lines.

we have same destination-patter (9.T) on all dial peers. Using preference make consistant outgoing call from line/dial-peer with lowest preference if line is avaialbe and I beleive that is what supposed to be.

Thanks,

Paolo Bevilacqua Mon, 02/18/2008 - 13:47

Yes, that's the way it's supposed to be. Now, there is a simpler way to simplify configuration, trunk-group. Under the voice port, assing a trunk-group. Reference this trunk-group instead of port under DP. This way you can reduce sensibely the number of DP. The if you still want an order of preference, this is also possible.

Latest recommendation, get ISDN if possible at all, and you will be enjoying a set of new features.

Actions

This Discussion