1841 router vlan vtp problems

Unanswered Question
Feb 18th, 2008

Hi everyone

I have a 1841 router with a 1 adsl wic and 1 4esw wic

here is my problem:-

I have configured the router with the relevant vlan interfaces

for 3 vlans

interface Vlan1

ip address

no ip redirects

ip nat inside

ip virtual-reassembly


interface Vlan2

ip address

no ip redirects

ip nat inside

ip virtual-reassembly


interface Vlan3

ip address

no ip redirects

ip nat inside

ip virtual-reassembly

the 1841 is the vtp server for the domain, and the links are trunking through the 4esw wic,

however when I created a new vlan vtp isn't being updated.

I have to go to the vlan database and created the vlan before vtp updates, from my other routers ie 877 etc when ever I create a vlan vtp is updated accordingly,

I hope this makes sense, this is really annoying me and i'm wondering if anyone else has had the same problem, if so would you mind letting me know how you overcome it.

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
vaisharm Mon, 02/18/2008 - 01:36


Please provide 'show vtp status' from 1841 and any other router in the same vtp domain. Is 1841 the only vtp server or are there any other vtp servers as well in the domain.


ddolbel Mon, 02/18/2008 - 02:25

hi thanks for your reply

there is only one vtp server and the cisco 1841 router is the vtp domain server the other devices are cisco 3750 switches.

as requested here is the info

ROUTER# sh vtp status

VTP Version : 2

Configuration Revision : 17

Maximum VLANs supported locally : 19

Number of existing VLANs : 6

VTP Operating Mode : Server

VTP Domain Name : domain-vtp

VTP Pruning Mode : Enabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

MD5 digest : 0x2A 0x25 0xCE 0x90 0xD3 0x53 0x15 0xF6

Configuration last modified by at 2-18-08 08:58:52

Local updater ID is on interface Vl1 (lowest numbered VLAN interface found)

If there is anything else you need please let me know.

ddolbel Mon, 02/18/2008 - 18:02

I have managed to work it out,

the vlan database is still updated from conf t

mode, using the vlan command ie

router(config)# vlan 10

router(config-vlan)# name vlan010

this command updated the vtp database,

which i have confirmed works do checking sh vtp status

and the revision increments each time i make a change,

I just wasn't aware of the vlan command in config mode,

I was also able to show the vlan's with the sh vlan-switch command

my problems have now been resolved, and I have shared my solution with you all.

thanks again for all the input.


This Discussion