backup for MPLS link

Answered Question
Feb 18th, 2008

Hi,

The customer is looking for failover link support for primary link on MPLS. WE are looking for ISDN and ethernet as a backup medium. Kindly see if the same can work.I have advanced IP services IOS on the router.

My query is that for the backup, do I need to involve the MPLS service provider to provide backup or can I provide backup link without the help of MPLS service provider.


Thanks in advance

Puneet

Correct Answer by shivlu jain about 9 years 1 week ago

hi puneet


So now you can create a dialer group for your clinet on your ras. When the primary link fails the isdn will be intiated and the call comes to the ras after that it will be autheticated and foradd to the LNS and a L2 session will be intiatd for the same. Now you ca create a pool for the clinet on the ras when it gets authenticated it will get the ip from the pool and there shold be a loopback which is part of the vrf. In this way the communication will be possible. If you need configs please let me know i can forward the configs too Or you want to try at your end first.


regards

shivlu

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
shivlu jain Mon, 02/18/2008 - 05:13

No you can go without that. why donot you use the isdn for PSTN for dialing to your isp ras.


regards

shivlu

puneet_kandwal Mon, 02/18/2008 - 22:08

Hi, thanks for replying

Just o brief you about the case, i ave two loacation A(central) and B(remote).A is connected to 5 other sites including B on serial link via MPLS service provider. I want to have a backup link in site B such that If my primary link on MPLS fails in site B, my backup link on ISDN fires up in site B. The problem seems that although the call is being fired from site B to site A, the return traffic does not comes back as the primary route to site B is via serial link (MPLS).

let me know if there is a way to make this work.


Thanks in advance

Puneet.

spremkumar Mon, 02/18/2008 - 19:55

hi puneet


do provide more info on what kinda primary connectivity you have and the capacity of the primary link and whats the main idea behind going on for the backup.


are you planning this backup at your central location or branch location.


typically branch locations you can consider a isdn as backup based on the user requirements and no of users in each branch.


if its for a central location then you need to think off a high capactiy backup link so taht you can serve your branch location without any service disruptions.


Its always better to involve/include your ISP in availing the backup service which mite cost you lesser than what you might end up in paying for your own backup link (point to point)...


regds


puneet_kandwal Mon, 02/18/2008 - 22:10

Hi, thanks for replying

Just o brief you about the case, i ave two loacation A(central) and B(remote).A is connected to 5 other sites including B on serial link via MPLS service provider. I want to have a backup link in site B such that If my primary link on MPLS fails in site B, my backup link on ISDN fires up in site B. The problem seems that although the call is being fired from site B to site A, the return traffic does not comes back as the primary route to site B is via serial link (MPLS).

let me know if there is a way to make this work.


Thanks in advance

Puneet.

spremkumar Mon, 02/18/2008 - 22:26

Hi


Is your primary link getting termianted onto an ethernet port ?


if possible can you post the config of your site B?


when the isdn is connected did u check out for the availability of the ip route in your router at site B?


regds


puneet_kandwal Mon, 02/18/2008 - 23:43

hi,

the primary link is on wic-1t connected to mpls cloud.

i am sending the config

runn

Building configuration...


Current configuration : 1865 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xxx-Fxx-RTR01

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

ip cef

!

!

!

!

multilink bundle-name authenticated

isdn switch-type basic-net3

archive

log config

hidekeys

class-map match-any interactive_av

match access-group name interactive_av

policy-map child

class interactive_av

priority 384

class class-default

bandwidth 128

queue-limit 512

policy-map parent

class class-default

shape average 2048000

service-policy child

policy-map set_precedence

class interactive_av

set ip precedence 5

interface FastEthernet0/0

ip address 172.21.0.254 255.255.0.0

duplex auto

speed auto

no keepalive

service-policy input set_precedence

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/0/0

ip address 192.168.1xx.3x 255.255.255.252

max-reserved-bandwidth 100

service-policy output parent

interface BRI0/1/0

description ###BACKUP LINK##

ip address 192.168.x0.2 255.255.255.xx2

encapsulation ppp

dialer idle-timeout 1000

dialer string 95114xxx17xx

dialer load-threshold 32 either

isdn switch-type basic-net3

isdn point-to-point-setup

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.xx6.xx

ip route 0.0.0.0 0.0.0.0 BRI0/1/0 254

ip http server

no ip http secure-server

ip access-list extended interactive_av

permit ip host 172.21.0.10 any


ip sla 1

icmp-echo 172.16.0.254 source-interface Serial0/0/0

threshold 5

frequency 100

ip sla schedule 1 life forever start-time now

access-list 111 permit ip any any

dialer-list 1 protocol ip permit

control-plane

line con 0

line aux 0

line vty 0 4

password cisco

login

scheduler allocate 20000 1000

end

pls let me know if this solution can work or not.


Thanks in advance

Puneet Kandwal

Correct Answer
shivlu jain Tue, 02/19/2008 - 00:22

hi puneet


So now you can create a dialer group for your clinet on your ras. When the primary link fails the isdn will be intiated and the call comes to the ras after that it will be autheticated and foradd to the LNS and a L2 session will be intiatd for the same. Now you ca create a pool for the clinet on the ras when it gets authenticated it will get the ip from the pool and there shold be a loopback which is part of the vrf. In this way the communication will be possible. If you need configs please let me know i can forward the configs too Or you want to try at your end first.


regards

shivlu

Actions

This Discussion