Cisco 7961G-GE: Problem upgrading firmware and converting from SCCP to SIP

Unanswered Question
Feb 18th, 2008
User Badges:

I have a brand new Cisco 7961G-GE, purchased with an additional licence to cover SIP usage. As supplied, the phone has an SCCP image. I need to convert it to SIP and install the latest firmware.


I downloaded P0S3-08-8-00.zip and copied OS79XX.TXT, P003-08-8-00.bin, P003-08-8-00.sbn, P0S3-08-8-00.loads and P0S3-08-8-00.sb2 to the TFTP server's root directory. I also created a SEP<MAC ID>.cnf.xml file in the root directory containing the following lines:


<device>

<loadInformation>P0S3-08-8-00</loadInformation>

</device>


When I turn the phone on, it successfully obtains SEP<MAC ID>.cnf.xml and P0S3-08-8-00.loads from the TFTP server. However, the upgrade does not complete successfully. The messages displayed at the bottom left corner of the phone's screen get no further than 'Verifying load'. The following entry appears in Status Messages:


Load Authentication Failed P0S3-08-8-00


The files listed in Firmware Versions are:


Load File: TERM61.DEFAULT

App Load ID: Jar41.2-9-1-45.sbn

JVM Load ID: CVM41.2-0-1-45.sbn

OS Load ID: onu41.2-7-5-50.sbn

Boot Load ID: boot41.3-2-2-0.bin


I tried upgrading to earlier SIP and SCCP images, such as 7.x, to see if it would be possible to get to 8.x in stages. But the same problem occurred. So far, I have been unable to find any way of getting the phone to accept an upgrade of any type.


Having searched online, including this forum, I can see that this problem is quite common. However, I have been unable to find a solution. I would appreciate any assistance you can offer.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Mon, 02/18/2008 - 13:35
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, first of all, do you have the sip files ?


if yes, try a factory reset, power on with #, release when led flash in patter, press 123456789*0#, phone will reset and load term61.default.loads.


patrick1962 Tue, 02/19/2008 - 04:11
User Badges:

Hi. Thanks for your reply. Which particular SIP files are you asking about? As noted in my original posting, I downloaded P0S3-08-8-00.zip and copied OS79XX.TXT, P003-08-8-00.bin, P003-08-8-00.sbn, P0S3-08-8-00.loads and P0S3-08-8-00.sb2 to the TFTP server's root directory. If I understand this correctly, the P0S3-* files constitute the SIP image. Are any other files etc needed?


The phone is also requesting a CTLSEP.tlv file, which is not present on the TFTP server. Is this needed? If so, what should it contain?


The SIPDefault.cnf and SIP.cnf files have not yet been configured and copied to TFTP server's root directory. However, I doubt that this explains the current problem since the TFTP server log shows that the phone is not getting as far as requesting them. It is failing with the 'Load Authentication Failed' error after downloading P0S3-08-8-00.loads.


I tried a factory reset as you suggested and the behaviour has now changed in two ways. (1) A 'CCM Configuration Unavailable' message is now appearing on the phone's screen. (2) Rather than attempting the upgrade once after being switched on, the phone now appears to be stuck in a loop, repeatedly downloading the same files and failing with the same error message.


Please let me know what you advise.

daveric78 Thu, 02/28/2008 - 06:29
User Badges:

hello Patrick1962. im writting from spain. I need help, and i dont know if you could help me. I have a cisco 7961 g. i have been trying updradred for sip but... i believe that my cisco has died. i believed that upgrade it, he need reboot it, and then for factory reset of the phone, hold down the '#' as the phone powers up. Then dial '123456789*0#. Now, when i turn on the telephone, always trying updated, and not start. i dont know how update it for use as SIP, it's often not even have the necessary files. Could you help me?

paolo bevilacqua Thu, 02/28/2008 - 06:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi daveric, if you don't have the files, you cannot upgrade the phone.

The thing is that cisco requires that you buy a service contract for the phone in order to download files, for a phone it is not very expensive, it can be about 20 usd.


The exception is the 7940 and 7960 phones, for which cisco has made the sip files available to the public.

Actions

This Discussion