WLC (4404) Etherchannel at CatOS Hybrid 6500 Problems

Unanswered Question
Feb 19th, 2008
User Badges:

Hi,


we've running a 4404 WLC with Quad gigabit Channel at Catos (PAGP Channel and src/dest ip mode). If we disable or disconnect one port of the quad connection, the trasmission of packets from some of our packets to the wlc is interrupted several minutes. We can reproduce that issue - is takes also minutes until that port comes op again in the etherchannel of the switch. Does anyone knows that problem or anyone running catos catalysts with wlc channels ?


Thanks for suggestions

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
irisrios Tue, 02/26/2008 - 07:09
User Badges:
  • Silver, 250 points or more

If etherchannel is configured on the controller and if any of the ports on the ontroller ports fail, traffic is automatically migrated to one of the other ports. check if the etherchannel is configured right on the swithc . Refer URL http://cisco.com/en/US/docs/switches/lan/catalyst6500/catos/7.x/configuration/guide/channel.html for more information

Scott Fella Tue, 02/26/2008 - 08:08
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

How are you setting up the etherchannel... what commands di you enter? The thing is that the WLC doesn't use PAgP or LACP. That is why you have to set the portchannel to on. Verify that the WLC is set to LAG and that you reboot the WLC.

dkroske Wed, 02/27/2008 - 06:39
User Badges:

We're experiencing a similar problem and I'm not able to find a technote that suggests how to implement LAG on the 6500 in a non-WiSM environment. Can you suggest one?

dneckermann Wed, 02/27/2008 - 08:28
User Badges:

Currently we try to garther more informations about the problem via cisco. I think that the catos works with a different protocol (only lacp or pagp) and doesen't work without any protocol. We also get the effect that if you shut or disconnect one switchport the wlc doesn't recognize that and trys to forward traffic to the switch. If we changed the 6500 spu2 to one which runs native ios the problem doesn't occur with channel set to mode on. Fact is that there isn't much information about the "needs" of the switch where the wlc is connected to. In the wlc guide is only the ios port configuration that we exactly used in our catos 6500.

sringer Thu, 03/13/2008 - 08:42
User Badges:

Had a similar problem with LAG on my 4402 connecting to a 6500 with CatOS. The TAC solution was:

1: Ensure you are performing IP src destination load balancing across the port-channel to the WLC, with the command - set port channel all distribution ip both

2: turn off spanning-tree

set spantree port fast _/__ enable

set spantree port fast _/__ enable

3: set trunk mode to ON.


dneckermann Mon, 03/31/2008 - 06:20
User Badges:

The problem was the setting of the wlc ports to "hard 1000SX" -> If your enable this you get several error with the Links of the SFPs. Don't disable the auto nego option !


Viten Patel Thu, 09/08/2011 - 09:13
User Badges:
  • Cisco Employee,

I was working on a similar issue.


I wanted to enable LAG on wlc 5508 connected to a 6513 running CatOS. I am not sure if the following would do the trick?


In the config guide I noticed that if you
set the PAgP mode as 'on', it will force the port to channel without
PAgP -

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/catos/8.x/conf
iguration/guide/channel.html#wp1026630

Set port channel port-list mode on  (which will force the port to channel
without PAgP and then issue this command)

Set port channel port-list on

Actions

This Discussion