UC520 voicemail / auto attendent help

Unanswered Question
Feb 19th, 2008

Setting up a new UC520 and having problem getting the voicemail or autoattendent to work. Inbound and outbound calls to phones other than the AA / VM work fine.

If I run a debug on the call or look at dial peer stats, the peer associated with AA gets a cause code 1 back.

Last Disconnect Cause is "1 ",

Last Disconnect Text is "unassigned number (1)",

Last Setup Time = 171194.

Last Disconnect Time = 0.

The dial peer is getting matched against on the call, but it seems like the integrated service isn't answering the call.

This is the default setup:

dial-peer voice 2000 voip

destination-pattern 501


session protocol sipv2

session target ipv4:

codec g711ulaw

no vad


The same occurance happens whether calling by extension internally, or trying from the world.

I have tried with the factory fresh configuration and just putting in auto attendent configuration, but it behaves the same. It seems like the service just isn't listening of the call.

If I run a debug call it shows the following:

Feb 19 17:22:34.083: //32/176E96148050/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x8547A3D4

State of The Call : STATE_DEAD

TCP Sockets Used : NO

Calling Number : 202

Called Number : 501

Source IP Address (Sig ):

Destn SIP Req Addr:Port :

Destn SIP Resp Addr:Port :

Destination Name :

Feb 19 17:22:34.083: //32/176E96148050/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream : 1

Negotiated Codec : No Codec

Negotiated Codec Bytes : 0

Nego. Codec payload : 255 (tx), 255 (rx)

Negotiated Dtmf-relay : 0

Dtmf-relay Payload : 0 (tx), 0 (rx)

Source IP Address (Media):

Source IP Port (Media): 16452

Destn IP Address (Media):

Destn IP Port (Media): 0

Orig Destn IP Address:Port (Media):

Feb 19 17:22:34.083: //32/176E96148050/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC) : 1

Disconnect Cause (SIP) : 404

Any thoughts on what is missing?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
smalkeric Tue, 02/26/2008 - 08:35

Could you provide the details of the debug commands:

debug isdn q931

debug dialpeer

debug voip ccapi inout

This issue can occur if the dial-peer is configured incorrectly.


This Discussion