invalid arp issue

Unanswered Question
Feb 19th, 2008

we had an issue at one of our site where we have 2 Windows 2003 Print servers. We have approx 80 printers configured on both of these print servers. One is the primary and the other is secondary. Both the print servers are connected to our switches in the MDF. The issue we were facing was that both the print servers could not communicate to the printers that were connected to our IDF-A switches. The print servers could not ping the IDF-A switches and the 8 or 9 printers connected to the IDF-A switches but the print servers could connect to all the other printers in our network that were connected to different IDF switches. On the print servers I could not see arp resolved for the printers it would show me 0000.0000.0000 invalid arp. The issue was resolved when I typed “clear mac-address-table dynamic” command on the IDF-A switches.

By the way I could connect to the IDF-A switches and the printers connected to IDF-A from all the servers except the 2 print servers. I would like to know what might have caused this issue on the switches. Any suggestions or comments will be highly appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Hieu Cao Tue, 02/19/2008 - 18:36

Are these 2 print servers and 8-9 non-pingable printers in the same subnet with same default gateway?

Have you attempted to power reset those 9 printers?

Can you connect to those 9 printers via web browser?

Do a "show log" in your switch....what infomration do you see ?



ismailsh12 Wed, 02/20/2008 - 08:12


The 2 print servers and the 8 or 9 printers are in the same subnet with same default gateway. We did attempt to power reset those printers but it did not fix the issue. When we had the issue, I could connect to the printers via web browser. All systems were able to connect to the printers except the 2 print servers. Show log on the switch did not show any errors. The way I fixed the issue was by "clear mac-address dynamic" command on the IDFA switches.



Hieu Cao Wed, 02/20/2008 - 17:22

Have you tried upgrading the network controller firmware in those printers? I think it's worth a try on one of those problematic printers.

Have you tried connecting them to different ports in the same switch?

Are speed / duplex set at the same level at both switch port and printer?




This Discussion