Vlan Interface Stays Admin Down

Unanswered Question
Feb 19th, 2008

I was not able to "un shut" Interface Vlan 10. Switch took "no shut" with no complains but interface stays Admin Down. This is on a WS-C3524-XL-EN Version 12.0(5.2)XU.

Below is the config.

SFS-EMC-Switch#sho run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SFS-EMC-Switch

!

enable secret xxx

!

!

!

!

!

clock timezone PST -8

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

description Trunk to 6509

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

switchport access vlan 61

!

interface FastEthernet0/14

switchport access vlan 61

!

interface FastEthernet0/15

switchport access vlan 61

!

interface FastEthernet0/16

switchport access vlan 61

!

interface FastEthernet0/17

switchport access vlan 62

!

interface FastEthernet0/18

switchport access vlan 62

!

interface FastEthernet0/19

switchport access vlan 62

!

interface FastEthernet0/20

switchport access vlan 62

!

interface FastEthernet0/21

switchport access vlan 62

!

interface FastEthernet0/22

switchport access vlan 62

!

interface FastEthernet0/23

switchport access vlan 62

!

interface FastEthernet0/24

switchport access vlan 62

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

no ip directed-broadcast

no ip route-cache

!

interface VLAN10

ip address 172.16.64.40 255.255.192.0

no ip directed-broadcast

no ip route-cache

shutdown

!

!

line con 0

transport input none

stopbits 1

line vty 0 4

line vty 5 15

login

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
everestm Tue, 02/19/2008 - 20:46

Have you tried doing a 'shut' on int vlan 1 first?

Everest

nguyenvinnie Tue, 02/19/2008 - 21:05

No, I did not. Will try this when I come to work in the morning. Thanks

shivlu jain Tue, 02/19/2008 - 20:48

Vlan interface shows down only that time when you were not entered the vlan command manually. So do the given below in your switch

router(config)#vlan 10

router(config-vlan)#exit

after that your vlan interface comes up.

Simply create a vlan

regards

shivlu

a.cruea1980 Wed, 02/20/2008 - 05:06

You can also assign VLAN 10 a loopback and "no shut" the loopback interface. That will bring up your VLAN.

Also, since your port is in trunk mode, I'm not sure "switchport access" really does much. I could be quite wrong on that, though.

nguyenvinnie Wed, 02/20/2008 - 08:50

Shivlu, problem solved when I shut down Vlan1.

a.cruea1980, I think you're right on "switchport access", it doesn't do much since it's in trunk mode already.

I have one more question, there're 2 vlans (61,62) in this switch, these 2 vlans info will it automatically passing throug the trunk? In another word, will I be able to access to these 2 vlans from remote.

The reason I ask, because On CatOS these 2 vlans have to be allowed thru the trunk by configuration.

everestm Wed, 02/20/2008 - 11:47

All configured VLans will go through the trunk by default. You can limit them by manually defining allowed vlans on the trunk interface using the "switchport trunk allowed vlan x,x,x" command.

Hope this helps!

Everest

Edison Ortiz Wed, 02/20/2008 - 12:12

3524 is a layer2 switch and only allows you to have one management interface up/up at the same time. You need to choose either Vlan1 or Vlan10 to be your management Vlan.

__

Edison.

Actions

This Discussion