IP phone stuck when a power cycle is performed

Unanswered Question
Feb 20th, 2008

IP hone 7941 is not booting.

It stuck while booting. Only speaker LED is green. There is no display.

Tried to reset to factory default but failed.

Please suggest how can repair the phone.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
connollyn Wed, 02/20/2008 - 02:53

I have had plenty of them. Return to cisco as faulty phone.

Paolo Bevilacqua Wed, 02/20/2008 - 03:09

No, don't return anything yet.


The phone wants:


1. a valid dhcp reply containing option 150 with the tftp address (callmanager if you use it)


2. file term41.default.loads and all the individual firmware files.


Once these conditions are meet, phone will start again. It can take 10 minutes at time with no display activity, so sometime is better to connect it to a pc with TFTPd32 and do things from there as it's easier to monitor the progress.


Hope this helps, please rate post if it does!

amitluthra Wed, 02/20/2008 - 03:54

1. a valid dhcp reply containing option 150 with the tftp address is OK in callmanager. Other phones are booting fine.


2. I had tried to reset the phone to factory default by sequence 123456789*0# But there is no changes still speaker light is green. I had kept the phone connected for 30 min.

Paolo Bevilacqua Wed, 02/20/2008 - 04:00

Hi, sometime callmanager problems or other network "variable" can prevent the process from completing successfully.


If you have a way to monitor the tftp request to callmanager (I personally don't know how to do that), you should be able to see a request fot term41.default.loads. You need this file together with the others, from a regular phoneload archive.


This is why to cut short I connect phones to either an IOS router or PC with tftp32d, and so far I've been 100% successful in recovering any and all "dead" phone.





Paolo Bevilacqua Wed, 02/20/2008 - 06:24

Download tftpd32 and install on PC. Enable DHCP server from settings button.

In the DHCP options field put 150 and the PC's address. Copy all firmware files in tftp directory.


Connect phone to PC via crossed cable or simple switch/hub on which no other DHCP server is present.


Monitor the process from the "log viewer" tab.

You will see all what the phone is doing.

amitluthra Wed, 02/20/2008 - 22:31

Thanks for the update.


Faulty phone is not picking up the IP from DHCP and there is no log generated in the log viewer.


Althogh I had tried with good phone it is picking up the IP and logs are generated in log viewer tab.


Anything else i can do.


Thanks

Paolo Bevilacqua Fri, 02/22/2008 - 06:37

Ok, in the dhcp settings you have set:


default gateway

name server

domain name


also try option 66 instead of 150, as well with PC's address.



Paolo Bevilacqua Tue, 02/26/2008 - 10:37

Look, the phone must be sending packets. On the same PC, do capture all with wireshark, attach the capture file here.

Paolo Bevilacqua Wed, 02/27/2008 - 02:11

Hi, there is no dhcp packets in the capture.


Please repeat the reset sequence and see if you can have the phone to emit dhcp request.

If it doesn't, then is dead.


Actions

This Discussion