Caller-ID not presenting a full digits

Unanswered Question

I have a problem when receiving incoming call. The router strips the leftmost digit (0) off and present only the last 10 digits. for example when caller (0123465245) calls, only 123465245 appears on the cisco IP phone.


Can somebody advice me on what needs to be configured on the callmanger router to rectify this issue.


The following are configuration of

voip


dial-peer voice 120 pots

description Incoming calls on BRI 0/2/0

incoming called-number .

direct-inward-dial

port 0/2/0


dial-peer voice 121 pots

description Incoming calls on BRI 0/2/1

incoming called-number .

direct-inward-dial

port 0/2/1


dial-peer voice 130 pots

trunkgroup Outgoing

description All Outgoing calls

destination-pattern 9T


dial-peer voice 100 voip

destination-pattern 5...

session protocol sipv2

session target ipv4:192.x.x.x

dtmf-relay sip-notify

codec g711ulaw

no vad




Thank





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 02/20/2008 - 04:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Where are you located? That is typical of countries that make use of dedicated fields in ISDN setup. So you do:


voice translation-profile addzero

translate calling 300


voice translation-rule 300

rule 1 // /0/ type national national

rule 2 // /00/ type international international


trunk group Outgoing

translation-profile incoming addzero


Hope this helps, please rate post if it does!


paolo bevilacqua Wed, 02/20/2008 - 05:44
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Then yes the above should apply to you.

Hello,


I will also want to find out what needs to be configured so that the callManager router adds 9 infront of the callers number when returning a call received or missed.


currentely, I have to dial 9 and the caller's full number manualy.


Any ideas on how to make this work automatically without manualy dial the caller's numbers





Zin.Karzazi Wed, 02/20/2008 - 07:34
User Badges:
  • Silver, 250 points or more

If you are using H323 on your Gateway (and i see from your config , you are using H323) then there is no need to change anything on your Callmanager, hence the translation rule provided by bevilacqua will do it for you and forward the right digits to the CCM.

If you are talking about an MGCP GW, then you can use Service Parameter on your Callmanager to add the 9: National/Subscriber/International Number Prefix.

user-cisco Wed, 02/20/2008 - 12:30
User Badges:

hi


i have the same issue like descibed above (ip phones display the pstn caller ID without first left most digit) and i'm using ccm 5.1 with mgcp gateway, how can i handle this and make the full pstn number appears correctly on ip phones?


thanks



pcameron Wed, 02/20/2008 - 13:43
User Badges:
  • Cisco Employee,

Enable 'debug isdn q931' on the gateway to confirm exactly what digits are coming in from the telco, then you can configure a translation on the CCM to prefix the required number on the calling number.



user-cisco Wed, 02/20/2008 - 22:21
User Badges:

thank you pcameron, in case it needs some translation work on ccm, having this done by translation patterns on ccm to let appearance of the full number and to let users to make redials and dial from missed or received calls good ... but i tried this and it made a conflict with existing route patterns

do u have a solution for this problem?


thanks

Hello,


I have added the following command line but it is still not presenting the full digits.


trunk group outgoing

translation-profile incoming addzero


voice translation-profile addzero

translate calling 300


voice translation-rule 300

rule 1 // /0/ type national national

rule 2 // /00/ type international international


Can somebody advice me on what to do next.


Thanks








Zin.Karzazi Thu, 02/21/2008 - 03:23
User Badges:
  • Silver, 250 points or more

@CIsco-user:

as you are using CCM with MGCP do the following: Go to "Service Parameter"-> Advanced-> under the "Clusterwide Parameters (Device - Phone)" section, put the right digits that you want diplayed on your Phones in "National/Subscriber/International number prefix". ie: 0 for National, 00 for International.


The Path to those service parameter on the CCM 5.1 maybe different , but its there :).

paolo bevilacqua Thu, 02/21/2008 - 10:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you send out of "show trunk group" to see if the translation profile is correctly associated, and output of "debug isdn q931" with "term mon".


If you need to mask number please do that in minimum amount necessary, to permit understanding if the number is coming in with a leading 0 or not.

I have attached the sh trunk group and show history.


I am using the telnet connection to connect to the router remotely so I don't know how to get the debug isdn q931 output since am not using the console connection.


Is there a way I will be able to get the output without travelling to where the router is located.


thanks







Attachment: 
paolo bevilacqua Fri, 02/22/2008 - 04:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, "term mon" mentioned above let you see debug output via telnet.

Need to see an incoming call, its possible it is coming in "unknown" hence need to change translation-rule. Actually I seem to remember that is the case in UK.

what is the command line that can be used to get the output. because the

debug isdn q931 mon does not work.


so I did following on the router


CCME_Router#debug isdn q931 ?


I see only these options


asn1 ISDN Q931 ASN1 detail

detail ISDN Q931 packet detail

interface Specify interface for debugging


I will be very greatful if you could type the right command line for me to issue.


thanks







pcameron Fri, 02/22/2008 - 05:58
User Badges:
  • Cisco Employee,

'debug isdn q931 ' is all you need to do

paolo bevilacqua Fri, 02/22/2008 - 06:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, that "term mon" as mentioned above. If you still get no debug output, configure:

logging monitor debug



Zin.Karzazi Mon, 02/25/2008 - 09:10
User Badges:
  • Silver, 250 points or more

You need to Call in while you are in debug Mode, then save the output and post it here.

Actions

This Discussion