Multiple DID to unmatching internal Ext - CCME

Answered Question
Feb 20th, 2008


Does any know of a easy way to match say 200 DID's (PRI) to unmatching internal ext numbers - without creating a huge amount of dial peers, so ie. external number

0123456789 goes to 212

0123456799 to 267 ....etc etc

The example of this is when a company moves to CCME and keeps all their old phone numbers and internal extensions.

I have managed this whith creating 200 dial peers with an exact match number with a rule directing it to the internal number ...but there must be an easyer way to do this?


I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 8 years 8 months ago

Glad to now it worked - please remember to rate useful posts with the scrollbox below!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
schreiberwayne@... Thu, 02/21/2008 - 04:51

Thanks, nice one - this is what i am looking for, it is the non-contigous address space that was causing me issues. I presume this would just require secondaty numbers on the ext & a dialplan-pattern and a voice dial-peer to route calls correctly to the internal phones?


schreiberwayne@... Thu, 02/21/2008 - 09:08


Just tried this with the secondary number and using a default .T dial-peer - worked a treat.

Thank you. My first mistake was that i needed to strip of the Area code from the secondary number - once i did this it worked fine.

Cheers, Wayne

Correct Answer
Paolo Bevilacqua Thu, 02/21/2008 - 14:39

Glad to now it worked - please remember to rate useful posts with the scrollbox below!

aciscolook Wed, 05/07/2008 - 13:21


It worked! Thanks.

I have a quick follow-up question. When I configure the max-time-call-retry to 60 seconds, it still keeps calls in queue for 2.5 minutes. Can you tell me why this is so?

aciscolook Wed, 05/07/2008 - 14:08


The CME bacd AA has a parameter for the maximum time a call will sit in the queue.

That parameter is configured under the CME AA and is called param max-time-call-retry. I've configured this for 60 seconds but the call sits in the queue for about 2.5 minutes. It's as if it's ignoring my parameter.

Paolo Bevilacqua Wed, 05/07/2008 - 14:40

Try reloading the script: "call application voice load aa".

Like few others, that parameter is read only at init time.


This Discussion