cwcli invreport fail with - theBigBug,257,nulljava.lang.OutOfMemoryError

Answered Question
Feb 20th, 2008


in cli.log file.

When i tried to generate the same 'detailed device report' from GUI, it stayed in hanging state and then restarted the server.

Later I only had report for 3000 Devices out of approximately 7000.

I also tried:

Java Plugin runtime parameter - Xmx512m

Increased minimum and maximum heap in file to 512 MB and 1024 MB respectively.

I also upgraded to JRE 1.4.2_10.

No luck so far.

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 8 months ago

Sorry, I pasted the wrong path. Yes, this is the correct path for the RME

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Joe Clarke Wed, 02/20/2008 - 09:22

Try increasing the heap size in NMSROOT/MDC/tomcat/webapps/ipm/WEB-INF/classes/com/cisco/nm/ipmng/properties/cli/ from 512 to 1024.

As for the GUI, you will need to schedule this job to run as opposed to running it immediately. That way, it should take advantage of the increased heap size.

vijay sanwal Wed, 02/20/2008 - 23:50

Thanx for the idea Clarke. I dont have IPM, but i m going to try this for RME.

& the path would be:

C:\Program Files\CSCOpx\MDC\tomcat\webapps\rme\WEB-INF\classes\com\cisco\nm\rmeng\cli\framework\

I will post the results.

Correct Answer
Joe Clarke Wed, 02/20/2008 - 23:59

Sorry, I pasted the wrong path. Yes, this is the correct path for the RME


This Discussion