CUCM6 and SRST multicast MOH

Unanswered Question
Feb 20th, 2008

Hi,

I set up SRST Multicast according to the Cisco documentation, as far as I can tell. I have all sites using Multicast MOH. However when I make a test calls, I see ccm-manager moh sessions turned up and I see packets tx/rx. However, I hear nothing.

What am I doing wrong ?

I haven't uploaded the audio source to the callmanager, the audio source is uploaded to the flash mem

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Dhiman Wed, 02/20/2008 - 09:39

Where do you see the TX/RX increase, and are you sure you are looking at the Multicast Resource counter incrementing?

Can you verify:

1. The IP address/port in "multicast moh" must match the IP address/port being transmitted for the CODEC in use from the MOH Server. eg., 239.1.1.3 if incrementing by IP and using G.729.

2. There could be a problem with the IGMP snooping config. Try to disable it on the switch that your phone is connected to.

3. Make sure to set the max hops to '1' in the MOH server config.

Also, post "sh ip mroute count" for the MCAST address you are using.

cris_jimenez Wed, 02/20/2008 - 10:07

Hi,

1.

WCDFAVG01#show ccm-manager music-on-hold

Current active multicast sessions : 1

Multicast RTP port Packets Call Codec Incoming

Address number in/out id Interface

===================================================================

239.1.1.1 16384 284/284 1735 g711ulaw Gi0/0

WCDFAVG01#sh call active voice | include RemoteMedia

RemoteMediaIPAddress=239.1.1.1

RemoteMediaPort=16384

2. I disabled IGMP snooping and the issue remains

3. "sh ip mroute count" shows nothing

WCDFAVG01#show ip mroute count

WCDFAVG01#

I have a question though on the Music On Hold Server Audio Source, I only have the "sampleaudio source option"

the audio source that I'm trying to pull is

music-on-hold.au stored on the router only, not in CCM yet

Jaime Valencia Wed, 02/20/2008 - 10:18

did you configured the right multicast ip and port in both CUCM and the SRST GW?

Table 1 Example of the Differences Between Incrementing Multicast on IP Address and Incrementing Multicast on Port Number

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802d1c31.html#wp1089886

you need CUCM to instruct the phones to listen to a specific ip address and port, and the SRST GW needs to have that ip and port multicasting. do you have the loopback address configured as per the guide?

Integrating Cisco CallManager and Cisco SRST to Use Cisco SRST As a Multicast MOH Resource

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802d1c31.html

HTH

Tommer Catlin Wed, 02/20/2008 - 12:16

You also need to configure the loopback address at the router. This will tell the phones that are requesting MOH at the site, to hit the loopback address, then the MOH address. You may have it, but it's not in your config above or mentioned.

cris_jimenez Wed, 02/20/2008 - 13:49

I have the loopback address configured

I uploaded the audio source file to ccm allowing multicast

Configured the MOH server specifying the multicast IP address and port, on the audio file the hop is set to 1

I created the MRG and MRGL

added the MRGL to the GW and to the phones on the proper site

I created the MOH region specifying the g.711 codec usage.

on the remote gateway

I indeed have the loopback ip address configured

I have the audio file stored in the flash mem of the router

I configured the ip source-address

specified the moh {file name}

specified the multicast moh [multicast ip address] port [port] route [int gi ip address that is actually attached to the switch where the phones are attached] [loopback interface]

if i enable debuging while i'm on hold this is what i see

Feb 20 21:37:06.947: MoH route If GigabitEthernet0/0 ETHERNET 10.109.100.9 via A RP

Feb 20 21:37:06.947: MoH route If Loopback0 46 10.109.100.13 via 10.109.100.13

Feb 20 21:37:12.159: MoH route If GigabitEthernet0/0 ETHERNET 10.109.100.9 via A RP

Feb 20 21:37:12.159: MoH route If Loopback0 46 10.109.100.13 via 10.109.100.13

Feb 20 21:37:17.371: MoH route If GigabitEthernet0/0 ETHERNET 10.109.100.9 via ARP

Feb 20 21:37:17.371: MoH route If Loopback0 46 10.109.100.13 via 10.109.100.13

WCDFAVG01#

Feb 20 21:37:22.604: MoH route If GigabitEthernet0/0 ETHERNET 10.109.100.9 via ARP

Feb 20 21:37:22.604: MoH route If Loopback0 46 10.109.100.13 via 10.109.100.13

however i do not hear anything please advise

Tommer Catlin Wed, 02/20/2008 - 14:26

you may need to check your MRGLs, then reset everything for it take. The phone will also need to rebooted for the new configuration file to take place. It looks like you have it all correct!

cheers

MARTIN STREULE Wed, 02/20/2008 - 15:15

If you hear nothing, you can say at least that..

-CUCM is configured properly for MoH (or else you would hear tone on hold).

-If you see that the router sends traffic, it probably does (address and port correct)

You have the loopback configured and from your input it looks okay.

Are the phone and the router on the same subnet or is multicast routing enabled?

Are the region settings okay? MoH Server (CUCM) and phones should be able to connect with G711 (even if the traffic is "spoofed")

Good luck,

Martin

cris_jimenez Wed, 02/20/2008 - 15:23

Martin

the phones and the router are not on the same subnet

multicast routing is not ehabled

the regions are ok

I haven't tested from ip phone to ip phone

i'm testing form ip phone to the pstn

MARTIN STREULE Wed, 02/20/2008 - 15:58

You probably already have that:

http://www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/srs/srsinter/moh.htm

There is a pretty good troubleshooting section ("Troubleshooting Tips").

Here some text from there:

-If no MOH streams are shown, Cisco CallManager has not been correctly set up to provide the Cisco SRST gateway with MOH. A typical error is that Cisco CallManager has not been configured with an appropriate MOH resource. The configuration error might be that the required codec has not been enabled on Cisco CallManager (check the service parameters) or that no MRGL has been assigned to the gateway, or, if one has been assigned, it has insufficient resources. Check the IDS Event Viewer for error messages.

-Verify that the multicast address and RTP port number shown in the show ccm-manager music-on-hold command output match the multicast-address and port arguments in the moh multicast command configuration.

-Verify that the Packets in/out field shows a count that is incrementing. Repeat the show ccm-manager music-on-hold command to verify that the Packets in/out counters are incrementing.

-Verify that the codec field matches the codec type of the audio file stored in the Cisco SRST gateway's flash memory. If another codec value besides G.711 mu-law or G.711 a-law appears in the show ccm-manager music-on-hold command output, review the Cisco CallManager region for incorrect codec configuration. See the "Creating a Region for the MOH Server" section.

-The Incoming Interface field shows where the Cisco SRST gateway is to receive the multicast MOH packets. An interface must be listed, and it must be one of the interfaces included in the multicast moh command or the default IP source address, which is configured with the ip source-address command. See Step 9 in the "Enabling Multicast MOH on the Cisco SRST Gateway" section.

cris_jimenez Wed, 02/20/2008 - 16:24

while troubleshooting I saw the following

when i issue the show ccm-manager music-on-hold command

i see that the packets increases, however the incoming interface is the phsysical interface gi0/0, shouldn't that be the loopback interface ?

if so what do i need to do in order to change that

MARTIN STREULE Thu, 02/21/2008 - 00:09

interface Loopback10

description MoH Source Interface - not routed, only for MoH

ip address 10.255.255.254 255.255.255.255

!

interface FastEthernet0/0

ip address 10.241.46.10 255.255.254.0

!

ccm-manager music-on-hold

!

call-manager-fallback

limit-dn 7940 1

limit-dn 7960 1

limit-dn 7970 1

timeouts interdigit 5

ip source-address 10.241.46.10 port 2000

max-ephones 42

! dual line to enable transfer

max-dn 144 dual-line

! huntstops to prevent call-waiting

huntstop channel

no huntstop

system message primary Notbetrieb (#)

transfer-pattern .T

!

! MoH File must be in Flash, MC address and port same as in CCM

!

moh music-on-hold.wav

! I have loopback first, don't know if that's an issue

multicast moh 239.1.1.1 port 16384 route 10.255.255.254 10.241.46.10

time-format 24

date-format dd-mm-yy

Jaime Valencia Thu, 02/21/2008 - 08:40

the port/ip on which to multicast depends on two things:

the MOH audio source number

the config on the MOH: increase IP or increase port

in the thread one of my previous post contains the information, i just had a case on that and went thru hell trying to do the math of which port to use. cu had also enabled the G729 codec so the math also needs to take that in mind

in the end i pulled up a CUCM trace and looked for

02/12/2008 16:17:31.429 CCM|MohDControl - findMulticastSourceGivenSourceNum - Device Name = MOH_3, MohRegion = Multicast MOH Server, Audio Source Id = 11, Held Party Region = RG-Plattsburgh-WPTZ

in this case we were using source #11, soon after that line there is the IP and port that CUCM is telling the phone to listen while on hold, we matched the port (we were using increase port config) on the SRST GW and it started to work

HTH

Tommer Catlin Thu, 02/21/2008 - 08:42

Yup, it's not easy. If you are struggling with MOH, I would even rip out MOH and start over from scratch and go very slow and detailed about it. MOH from CUCM is easy. IOS multicast at the router is a pain to setup. But once it works, it's done. No more fiddling. If you are deploying any new site and are even THINKING of MOH at the site, do it now during install. Otherwise you will be reseting devices nonstop trying to figure out what the problem.

cris_jimenez Thu, 02/21/2008 - 08:43

the config on the MOH is set to increase IP

this is my router's config

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface GigabitEthernet0/0

description CORE SWITCH WCDFASW01 : IF FA1/0/47

ip address 10.109.100.9 255.255.255.252

duplex full

speed 100

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.110.21.21

ccm-manager mgcp

ccm-manager music-on-hold bind GigabitEthernet0/0

call-manager-fallback

secondary-dialtone 9

max-conferences 6 gain -6

ip source-address 10.109.100.9 port 2000

max-ephones 96

max-dn 288

transfer-pattern 41....

voicemail 919169284324

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384 route 10.1.1.1 10.109.100.9

Tommer Catlin Thu, 02/21/2008 - 08:46

Oh yeah, that is idea also. The MOH music you are using, trying using something from Cisco first before using your own music on hold file. I have had a problem before that MOH would not play and I thought it was my setup, multicast ports, loopback, etc and turns out, my MOH file was not the correct format. Get the Cisco MOH to play at the router, then move to your file.

MARTIN STREULE Thu, 02/21/2008 - 09:13

just saw in you config:

ccm-manager music-on-hold bind GigabitEthernet0/0

Try without the bind...

ccm-manager music-on-hold

MARTIN STREULE Thu, 02/21/2008 - 08:46

put the moh server in it's own place and configure G711 only between all sites and Moh and you never have to fiddle with something.

Configured literaly hundreds of sites - no problem at all.

Tommer Catlin Thu, 02/21/2008 - 08:52

Right, that's the easy way out of MOH. If you want to save your bandwidth for actual phone calls and data, put your MOH file on the SRST router so it's not streaming across the WAN links at 64k. If you have unlimited bandwidth, then it's easy to MOH from the servers. If you have a T1 line with 25 phones at the remote site, it does not make sense to stream the MOH from the CUCM

cris_jimenez Thu, 02/21/2008 - 08:56

the odd thing is that i have the file loaded in the flash mem.

right we want to deploy srst multicast moh to save BW

sh flash

-#- --length-- -----date/time------ path

1 33965560 Sep 25 2007 04:48:10 -07:00 c2800nm-advipservicesk9-mz.124-3h.bin

2 1826 Sep 25 2007 04:59:38 -07:00 sdmconfig-28xx.cfg

3 6036480 Sep 25 2007 05:00:04 -07:00 sdm.tar

4 861696 Sep 25 2007 05:00:20 -07:00 es.tar

5 1164288 Sep 25 2007 05:00:38 -07:00 common.tar

6 1038 Sep 25 2007 05:00:54 -07:00 home.shtml

7 113152 Sep 25 2007 05:01:08 -07:00 home.tar

8 527849 Sep 25 2007 05:01:26 -07:00 128MB.sdf

9 1697952 Sep 25 2007 05:01:48 -07:00 securedesktop-ios-3.1.1.45-k9.pkg

10 416354 Sep 25 2007 05:02:08 -07:00 sslclient-win-1.1.3.173.pkg

11 496521 Feb 15 2008 10:44:24 -08:00 music-on-hold.au

MARTIN STREULE Thu, 02/21/2008 - 09:03

I guess I have been misunderstood.

I'm not sending any MOH over the WAN -> MoH Multicast is not routed. The file is in the router's flash.

Even so the CUCM server (MOH) has to be configured to get the phones listening to the correct stream. It's way easier to stick with the default G711u.

What I meant is: put the Moh Server in it's own DevicePool/Region and make it G711 to everywhere (just the multicast one).

If I'm not sending MoH over the WAN it should not be important what codec I use anyway... :-)

The phone calls can still be G729.

A simple setup makes live easier.

cris_jimenez Fri, 02/22/2008 - 11:27

I think I have the same problem that your customer had.

If I configure the MOH server to increase based on IP

if I issue the show ccm-manager music-on-hold command

I see 239.1.1.5 port 16384

if I configure the MOH server to increase based on port number

if I issue the same command i see

239.1.1.1 port 16392

Based on the Table of the doc you posted

It's the audio source 2 which in my case is the audio source 2

however if I change either the port settings or the ip address settings on the router

the next time I test it and Issue the show ccm-manager music-on-hold command

the port is increased by 8

what am I missing

cris_jimenez Fri, 02/22/2008 - 11:47

I just gathered the trace and this is what i see

02/22/2008 11:18:53.111 CCM|MohDControl - findMulticastSourceGivenSourceNum - Device Name = MOH_2, MohRegion = MOH, Audio Source Id = 2, Held Party Region = Walnut Creek|DS1-0@WCDFAVG01.BAF.com>

02/22/2008 11:18:53.111 CCM|MohDControl - findMulticastSourceGivenSourceNum - HeldPartyCapCount=15, AudioSourceCapCount=1|DS1-0@WCDFAVG01.BAF.com>

tb33mid Thu, 02/28/2008 - 21:01

If you are multicasting from the router's flash "spoofing" have you checked the show ephone summary, to see that the file has been loaded correctly and shows no errors? Is the file g.711ulaw?

cris_jimenez Thu, 02/28/2008 - 21:05

yes,I checked pretty much everything. If I enable debugs the router shows that the streams are sent. I also have a cisco TAC case open, they don't know that to do.

I will keep you posted with the results

thank you very much for the support provided

chris.day@hunte... Tue, 05/04/2010 - 14:28

Just a quick thought.  From what I know the phones need to connect the caller to the MOH multicast source, make sure you have multicasting set up on your LAN.  I set up multicast on the switches, then went into the uplink interfaces and the voice vlans and issued the ip pim passive or dense mode.  I also made sure I had the ip pim settings on the router back into the LAN as well.  If you don't have pim setup from the router to the voice vlan you will run into issues with MOH.  Also make sure your MOH file is in ULAW encoding format if it's a wav file.

Actions

This Discussion