Mutual Redistribution and Routing Loop

Answered Question
Feb 20th, 2008
User Badges:

---<----0/1 (RIP) --- Router1 --- 0/0 (OSPF) ---<--- Router 2 ----<----^

|------------>----------------->-------------------->---------------->---------|



Router 1 configuration

----------------------


router ospf 1

redistribute rip metric 100

network 172.16.1.0 0.0.0.255 area 0

distribute-list x in FastEthernet0/0

!

router rip

version 2

redistribute ospf 1 metric 4

passive-interface FastEthernet0/0

network 192.168.5.0

redistribute-list y in FastEthernet0/1

!

access-list 1 permit 192.168.5.0 0.0.0.255

access-list 2 permit 172.16.1.0 0.0.0.255

!



Router 1 is doing mutual redistribution between OSPF and RIP. In terms of distribute-list, should x be 1 and y be 2 to prevent routing loop? Or should x be 2 and y be 1?


Thanks !


Correct Answer by lamav about 9 years 2 months ago

Hi, rather than memorize what you have to do, you may want to break it down so that you understand the method behind the madness, so to speak.


If you have a router that acts as a "go-between" for a RIP network and an OSPF network by doing mutual redistribution, you have to ensure that the OSPF routes that it learned from the OSPF Router are not re-learned and redistributed back to the OSPF router when the RIP router readvertises them as RIP routes.


For example, refer to the attached diagram. SEE NEXT POST.


Router A is a RIP router, Router B runs RIP and OSPF and router C is an OSPF router.


Router A advertises RIP networks 1-10 and Router C advertises OSPF networks 11-20.


Lets start with the OSPF router's interaction.


Router B will learn about OSPF routes 11-20 from OSPF Router C and then advertise them to Router A as if they were RIP routes (redistribute OSPF into RIP), right?


OK...


So RIP Router A will learn about OSPF networks 11-20 and enter them into its routing table as RIP networks. The next hop for networks 11-20 will be Router B, since it learned them from B.


Now comes the problem.


RIP Router A will then readvertise them to Router B 30 seconds later. If Router B does NOT filter the routes for networks 11-20, they will be readvertised back to the OSPF Router with reachability information (next hop) that will again point to Router B.


The OSPF process running on OSPF router C will think it has a valid route for what is really a network in the OSPF domain that has a next hop that points in the direction of an external system (Routers A).


HTH


Victor




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
lamav Wed, 02/20/2008 - 18:02
User Badges:
  • Blue, 1500 points or more

Hi, rather than memorize what you have to do, you may want to break it down so that you understand the method behind the madness, so to speak.


If you have a router that acts as a "go-between" for a RIP network and an OSPF network by doing mutual redistribution, you have to ensure that the OSPF routes that it learned from the OSPF Router are not re-learned and redistributed back to the OSPF router when the RIP router readvertises them as RIP routes.


For example, refer to the attached diagram. SEE NEXT POST.


Router A is a RIP router, Router B runs RIP and OSPF and router C is an OSPF router.


Router A advertises RIP networks 1-10 and Router C advertises OSPF networks 11-20.


Lets start with the OSPF router's interaction.


Router B will learn about OSPF routes 11-20 from OSPF Router C and then advertise them to Router A as if they were RIP routes (redistribute OSPF into RIP), right?


OK...


So RIP Router A will learn about OSPF networks 11-20 and enter them into its routing table as RIP networks. The next hop for networks 11-20 will be Router B, since it learned them from B.


Now comes the problem.


RIP Router A will then readvertise them to Router B 30 seconds later. If Router B does NOT filter the routes for networks 11-20, they will be readvertised back to the OSPF Router with reachability information (next hop) that will again point to Router B.


The OSPF process running on OSPF router C will think it has a valid route for what is really a network in the OSPF domain that has a next hop that points in the direction of an external system (Routers A).


HTH


Victor




Actions

This Discussion