restore (3745)router to boot to IOS

Unanswered Question
Feb 21st, 2008
User Badges:

I have a 3745 router that does not want to load the IOS. I am beginning to think that it is trashed. It continually hangs up when I try to boot from the default IOS. I have loaded a new IOS on the flash and tried to force it to boot to flash:file. It gives me the error message.


*** Unknown External CPU Interrupt ***

Stacked Cause = 0x4000, Stacked Status Reg = 0x34018003

Current Cause IP[7..0] = 0x40, Current SREG IP[7..0] = 0x80


I have included the entire boot process in the attachment. I do not want to walk away from this b/c I really do not want to buy new but I am out of ideas and have not found any docs that go beyond what I have already tried.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vaisharm Thu, 02/21/2008 - 07:43
User Badges:
  • Cisco Employee,

Hi,


If you have any modules installed on the router, take those out and then try to boot the router. Try the following from ROMMON:


Step1:


ROMMON1>boot

OR

ROMMON1>boot flash:c3745-is-mz.122-15.ZJ3.bin


If it fails:


Step2:


ROMMON1>confreg 0x2142 << This would ignore the startup config.

ROMMON1>reset


Follow step1 after the router drops back into ROMMON.


Step3:

If it still does not work, try reseating the DRAM and follow the same process.


Do capture everything and post it.


HTH,

Vaibhav

Richard Burts Thu, 02/21/2008 - 07:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

aaron


You provided good information about the issue in the file that you posted. I took a quick attempt with the error message to use the Output Interpreter and the Error Message Decoder on the Cisco site but neither tool came up with anything.


I am not sure about it but if I were guessing I would guess that there is a hardware failure of some kind. If the router were under a maintenance contract I would open a case with Cisco TAC. Would I assume from your message that a TAC case is not possible?


HTH


Rick

uwhadministrator Fri, 02/22/2008 - 06:56
User Badges:

It is no longer under smartnet. The results i got from the previous post were identical. as follows. There is only one module that is installed in the unit. It looks like it the back plane interface card with slots for a second CF card and the only console port. I have even tried moving the cf card to the slot0: to boot up with same results. Any ideas???




rommon 2 > dir flash:

program load complete, entry point: 0x80008000, size: 0xb2a0

Directory of flash:


2 20521424 -rw- c3745-is-mz.122-15.ZJ3.bin

5013 316942 -rw- CP79020101SCCP030530B.sbin

5091 307479 -rw- CP79050101SCCP030530B.sbin

5167 308284 -rw- CP79120101SCCP030530B.sbin

5243 1602 -rw- CiscoLogo.gif

5244 953 -rw- Delete.gif

5245 369950 -rw- P00303020214.bin

5336 333822 -rw- P00403020214.bin

5418 1347 -rw- Plus.gif

5419 47904 -rw- S00103020002.bin

5431 174 -rw- Tab.gif

5432 3624 -rw- admin_user.html

5433 546317 -rw- admin_user.js

5567 301298 -rw- ata18x-v2-16-ms-030327b.zup

5641 824044 -rw- cmterm_7920.3.3-01-02-021.bin

5843 16344 -rw- dom.js

5847 864 -rw- downarrow.gif

5848 6146 -rw- ephone_admin.html

5850 5478 -rw- logohome.gif

5852 496521 -rw- music-on-hold.au

5974 3503 -rw- normal_user.html

5975 76024 -rw- normal_user.js

5994 843 -rw- sxiconad.gif

5995 2267 -rw- telephony_service.html

5996 870 -rw- uparrow.gif

5997 9968 -rw- xml-test.html

6000 2453 -rw- xml.template

6001 660 -rw- vlan.dat

6002 18971964 -rw- c3745-is-mz.123-6.bin

10634 7799 -rw- demo-config

10636 10645 -rw- houston-old.cfg

rommon 3 > boot flash:c3745-is-mz.122-15.ZJ3.bin

program load complete, entry point: 0x80008000, size: 0xb2a0


program load complete, entry point: 0x80008000, size: 0x13920b4

Self decompressing the image : ############################################################################################################################################################################################################################## [OK]


Smart Init is enabled

smart init is sizing iomem

ID MEMORY_REQ TYPE

0002F7 0X005F3C00 C3745 Mainboard

0X00280000 OIR memory

0X000F3BB0 public buffer pools

0X00211000 public particle pools

TOTAL: 0X00B787B0


If any of the above Memory Requirements are

"UNKNOWN", you may be using an unsupported

configuration or there is a software problem and

system operation may be compromised.

Rounded IOMEM up to: 12Mb.

Using 9 percent iomem. [12Mb/128Mb]


*** Unknown External CPU Interrupt ***

Stacked Cause = 0x4000, Stacked Status Reg = 0x34018003

Current Cause IP[7..0] = 0x40, Current SREG IP[7..0] = 0x80

Actions

This Discussion