server initiated connections, CSM - Default Gateway ?

Unanswered Question
Feb 21st, 2008

Hi !

I am trying to configure server-initiated connections. As the server needs to access several destinations - I need to configure a default gateway.

I did:

vlan 110 client

ip address



vlan 130 server

ip address


static nat


static nat yyy.yyy.yyy.yyy


The server has configured the Alias address as a gateway - but the CSM does not send the request.

When I enter a "route xx.xx.xx.xx /24 gateway" command it works..


I need to access several destinations - not only one...

Doesn`t it support a default-gateway configuration ?

I would really appreciate any help...



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
pknoops Thu, 02/21/2008 - 17:24

Hi Hans,

Another way to do this is to create a dummy serverfarm for the outbound requests.

Something like this:

Nat pool test netmask

vserver outboundnat

virtual any

serverfarm routeout

vlan servervlan


serverfarm routeout

no nat server

nat client test

predictor forward

When a device in the server vlan initiates a connection it is caght by the vserver and

will be client natted to the natpool address and routed out by the CSM.

This is how many people setup outbound server initiated connections.



Gilles Dufour Fri, 02/22/2008 - 00:44

do you have another gateway configured on a different vlan ?

The CSM will only use 1 gateway. The first one configured or the first one to respond to arp request after reboot or failover.

So, if you have another gateway configured, that's the one the CSM will use to forward the traffic.

Configuring a vserver with a 'predictor forward' serverfarm won't change anything if this is a routing issue.



This Discussion