Isuue with schedules in Unity 4.2

Unanswered Question
Feb 21st, 2008
User Badges:

Hello Experts,

I have been experiencing a very weird problem. I have a CTI route point (8888) which points to a hunt group (8604). In the Unity I have created a custom schedule. In the open option of the CH, I am asking the system to ring the hunt group pilot number (8604)and it works fine. In the close option I am asking the system to ring another internal extension (8916) but as soon as the schedule is set to close, the call goes to 8888's voicemail without ringing the extension (8916). This problem has been bugging me for few days. Do you guys have any idea why this is happening?


Thanks,


MK

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
lindborg Thu, 02/21/2008 - 11:16
User Badges:
  • Cisco Employee,

Little hard to say right off hand - one thing that would help is to pop open the port status monitor tool in Tools Depot (not the web based viewer) and capture the flow when you come through durring day hours (which seems to work as you want) and then another one where it's after hours that's not - then we can see what handlers/conversations are being touched.


My first guess is the routing rule that's picking up the call routing in from 8604 is not being fired on after hours when the call is coming in from 8888 - the port status monitor should show the calling/called number information on the inbound calls which may clear this up.

mightyking Thu, 02/21/2008 - 12:20
User Badges:

Thanks Jeff,

I am attaching the output of the Port Status monitor tool along with callhandler config. Could you please have a look and let me know if you see anything wrong.


Thanks,


MK

mightyking Thu, 02/21/2008 - 12:20
User Badges:

Thanks Jeff,

I am attaching the output of the Port Status monitor tool along with callhandler config. Could you please have a look and let me know if you see anything wrong.


Thanks,


MK



mightyking Thu, 02/21/2008 - 17:34
User Badges:

Anybody has any idea before I open a case with TAC?


Thanks,


MK

lindborg Fri, 02/22/2008 - 15:36
User Badges:
  • Cisco Employee,

So one of these is a direct call and one is a forwarded call? If so, I know what's happening.


On the direct call your rule kicks in and you send to the attempt transfer entry point for the help desk and it works. As it should.


However on a forwarded call, the first handler that Unity loads it will force the skip of the transfer rule and go right to the greeting no matter what to avoid transfer loops. So it goes right to the greeting in that case.


You can get aorund this behavior by having the closed contact greeting rule on that handler blank and set for an after greeting action to attempt transfer to another call handler which is set to ring the help desk number. This "chaining" technique gets around the tranfer "boomerang" prevention device on forwarded calls.

Ayodeji Okanlawon Sun, 02/24/2008 - 00:55
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Jeff,


This is exactly how I have my system setup and it works perfectly.


I am planning to put together a short documentation on setting up typical scenarios like this.


I have used the documentation from your Audio Text Applications Guide. Its fantastic.!!!!


Most of the problems I have seen guys encountered here, I have solved them using this documentation.


I plan to put together a shord vivid description of how to sep up common things like


1. Transfering calls to external numbers


2. Using same key to transfer calls to different handlers during office hours and out of office hours


3. Seting up General Group Mail box


4. Using Unity as a MeetMe Conference Manager


5. Setting up Advanced Auto Attendant.


I have observed that these are tyhe comon problems engineers experience based on posts on this forum and after studying your documentation I was able to get all of thos to work.


This will be coming shortly.

mightyking Mon, 02/25/2008 - 08:40
User Badges:

Hello Guys,

Please see the attached file and let me know if I am doing something wrong because it's not working. Your help is greatly appreciated.


Thanks,



Ayodeji Okanlawon Mon, 02/25/2008 - 11:22
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Hi,


For this to work you will need do th following:


1.Create two schedules: Business hours and off Hours( You caan use any name you want)


2. Ensure the shedules are exact opposite of each other, eg 8am-5pm and 5pm-8am


3. Assign your Helpdesk Open CH to Business hours schedule


4. Assign your helpdesk close CH to off hours schedule


5. On the call transfer rule for Helpdesk open, enable the closed transfer as you have done.


6. On the xfer incoming calls, leave as xfer to directly to handlers greetings (as you have it)


7.On the greetings for helpdesk open, set the closed greeting to blank (as you have it) and after greeting to to send aller to CH: attempt xfer for Helpdesk-Close CH (as you have it)


8. On the Helpdesk-close CH, ensure that its in the off hours schedule, select the standard xfer rule to ring an extension: 8916.


Make sure the closed, alternate and busy xfer rule are disabled. ( You got this part wrong so correct it and try again)


Thats all.


cheers

mightyking Wed, 02/27/2008 - 06:52
User Badges:

Hello Deji,

I did exactly what you told me but the close schedule is still going to the voicemail. I am sending you the config with all changes, please have a look and let me know if I am missing anything.


Thanks,


MK



Ayodeji Okanlawon Wed, 02/27/2008 - 12:38
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Mighty King,


There is a problem with your schedule.


Your schedule for Helpdesk-Open is 7am - 10am

Your schedule for Helpdesk-close is 7am -10am.


The schedules are the same.


It has to be opposite. So if Helpdesk open is 7am-10am then helpdesk close has to be 10am-7am(the next day) So you will have to uncheck the 7am, 8am and 9am on helpdesk close and ckeck from 10am to 7am...


When you are testing makesure for helpdesk close, you adjust unity time to match the time you are testing against.

mightyking Thu, 02/28/2008 - 08:08
User Badges:

Thanks for the reply Deji.

I modified both schelules but no luck. it still goes to the voicemail. Please see the attached file.


Thanks,


MK



Ayodeji Okanlawon Thu, 02/28/2008 - 08:40
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

How are you testing it.


WHat time did you do the test.


what time was on your PC time when you tested.


Can you lunch ATM (audio text manager form unity tools) and check that on the CH for closed hours, the alternate greeting is not enabled.

mightyking Thu, 02/28/2008 - 09:28
User Badges:

Deji,

I am uploading the output of the ATM for the HelpDesk-Close CallHandler and Call Viewer for the time of test. At this time the close schedule has to be applied and ring the extension 8916 but it doesn't. It goes to the voicemail.


I realy appreciate you help,


MK



Ayodeji Okanlawon Thu, 02/28/2008 - 22:52
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

MK,


You are dialing 8888 from 8916, the same number you want it to ring after closed hours.


Unity dials the number and sees it as busy and then it forwards the call. So Unity is treating it as a forwarded number from 8888 and the rule is that a forwarded call will go to the subscriber or CH's greetings.


This is very simple. Dial 8888 from 8604 for the closed hours schedule and see what happens.


Make sure that on your cti route point 8888, you have the CFA to one of your voice-mail's port.

Make sure that on your call routing table you do not have any forwarding rule there.

mightyking Fri, 02/29/2008 - 07:58
User Badges:

Deji,

Although I can receive multiple calls on my extension (8916) but I tried calling 8888 from another extension with the same result. The call is forwarded to the voice mail when the time is after hour.


Thanks Deji,


MK

Ayodeji Okanlawon Tue, 03/04/2008 - 03:33
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Mk,


Can you go to your call routing table. If you have anything conmfigured can you send me a screen shot of both your forwarded calls and direct calls.

mightyking Mon, 03/10/2008 - 09:40
User Badges:

Sorry for the delay Deji. I thought you gave up on this case. I am still having problem with the close schedule of the call handler. It still goes to the voicemail. Here's the print screen of the call routing config for 8888.


You help is very much appreciated,


MK

Ayodeji Okanlawon Tue, 03/11/2008 - 01:29
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

MK,


If you want to use call routing, then you will have to create another call routing rule that will be assigned to the closed schedule.


Just as you have the call routing for helpdesk open, you will need a call routing rule for helpdesk closed.


You will then send this to the CH for helpdesk closed.


However, since you have previosuly defined your CH, you can delete the call routing and you will be fine.


You dont need to use call routing to make this work. This is where your problem has been. Call routing will take precedence over evry other thing you have defined and since there is no call routing rule for helpdesk closed it wont work.


So solution is this;

Do one of the following:


1. delete this call routing rule or

2. Add a new call routing rule for helpdesk closed and assigne it to the closd schedule.


Take a look at this link and see how I have done mine.


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=Unified%20Communications%20Applications&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cbfd0fa

mightyking Wed, 03/12/2008 - 06:50
User Badges:

THANKS Deji, it worked.

I started by removing the call routing for HelpDesk-Open but it didn't work. Even the open schedule was going directly to the voicemail. There's something that I don't understand; I have an Auto Attendant (AA) which is configured exactly the same way. I am not using any closed call routing for the AA but it works fine but HelpDesk call handler was not working with the same config.


Now that you helped me to resolve this issue; please tell me how can I configure a voice mail for the helpdesk call handler. How Can I send the voicemail to every member of the helpdesk group. They are 4 people answering the calls. Is it possible to do so?


Thanks again Deji,


MK

Ayodeji Okanlawon Wed, 03/12/2008 - 06:55
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Let me understand you.


Do you mean you want to setup a group mailbox for the users?


As in you want them to have only one voice mail and for any one of them to be able to listen to it?

mightyking Wed, 03/12/2008 - 07:38
User Badges:

That's right. The extension is 8888 and 4 people are answering this number. I have a mailbox configured for 8888 but it doesn't seem to work. What I need is; when a call comes in, it rings the extensions of HelpDesk and goes to the voicemail in the case when nobody answers (During the open hours only). We need the received voice mail to be dispatched to all members of the group and if one of them deletes the message then it's deleted from 8888's voicemail. I associated a distributed list with 8888 but the voicemail doesn't kick in in order to test if the distribution list works. Is that how we do it?


Thanks,


MK

Ayodeji Okanlawon Wed, 03/12/2008 - 07:56
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

here is a post from Rob Huffman on how to how to do this..


In this example we are going to do what you are trying to do as well as Light the MWI Lamp on the phones within the Line Group when a Message is left for the group. We will need to setup a second "Dummy" line on the Line Group member phones for the Messaging portion of the config.


Lets say the Hunt Pilot number is 5999 and the Dummy Extension on the Line Group member phones is 2355. Set the Hunt Pilot to Forward (CFNA) to the Unity Pilot # 5000.


Create a mailbox for 2355 with 5999 as an Alternate Extension. When the call routes through to Unity via the Hunt Pilot No Answer Unity should see the CLID of 5999 which will then be connected to the Mailbox on 2355.


The only thing to verify is what CLID number is being passed to Unity should be 5999 in this example). You may need to configure the Originally Dialed number (whatever it is) as an Alternate Extension on 2355 as well.


Have you looked at using this feature?


Alternate Extensions


On the Alternate Extensions page for a user account, you can enter phone numbers to set up alternate extensions in addition to the primary extension of the user. Alternate extensions can be used for various reasons, such as handling multiple line appearances on user phones. Alternate extensions can also make calling Cisco Unity Connection from an alternate device,such as a cell phone, a home phone, or a phone at another work site more convenient.


When you specify the phone number for an alternative extension, Connection handles all calls from that number in the same way that it handles calls from a primary extension (assuming that ANI or caller ID is passed along to Connection from the phone system). This means that Connection associates the alternate phone number with the user account, and when a call comes from that number, Connection will prompt the user to enter their password and log on.


From this doc;


http://www.cisco.com/en/US/products/ps6509/products_administration_guide_chapter09186a00805570b6.html#wp1040977


Then tweak the Message Lamp Setting in CCM for the 2355 Line appearances;


For the Line Setting on 2355 (each phone)-


Line Settings for this Device - Changes affect only this device


Message Waiting Lamp Policy - Light and Prompt


The RED Message Lamp will then work for these Second lines on each phone.


Hope this helps!

Rob

mightyking Wed, 03/12/2008 - 12:37
User Badges:

Deji,

I tried Rob's great solution but not lucky enough to make it work. I am attaching the print screen of the config. Please let me know if I am missing something.


Thanks,


MK



Actions

This Discussion