cisco 2620xm + wic-1adsl limited

Unanswered Question
Feb 21st, 2008

Hi,

I have a 2620xm with a wic-1adsl, but when I download something, it's "limited" at 300KB/s...

If I use this wic-1adsl with a Cisco 1720, the same file download at 800KB/s.

Why?

The IOS on 2620xm is 12.4(16) ADVANCED ENTERPRISE SERVICE, it has 256MB of RAM and 32MB of flash.

the firmware of the wic-1adsl is 3.8131.

I have noticed an abnormal cpu utilization of 42% when i download.

If I modify my network topology in this way:

1720+wic-1adsl <---- 2620xm <---- PC

I downlaod from internet at 800KB/s but the 2620xm cpu utilization is 86%.

it's normal?

Regards,

Fabio Dolcino

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
Loading.
jaxel_rulez Fri, 02/22/2008 - 00:54

Nobody can help me?

I'm italian, excuse me if i don't speak english very well!

Thanks!

Fabio Dolcino

Goutam Sanyal Fri, 02/22/2008 - 02:33

Hi Fabio Dolcino,

1stly u are speaking english very well.

2ndly can u post the output of "debug packet","sh processes cpu history" & "sh environment all" when u r downloading.

Lets c, how much I can help you. :)

Thanks

Goutam

jaxel_rulez Fri, 02/22/2008 - 15:39

Hi Goutam!

Thank you for the compliment and for your availability!

The "debug packet" don't produce output but the other commands yes.

Today, I have changed the IOS image with a c2600-entbase-mz.123-10 and I download at 800-850KB/s...but, when I have charged a c2600-adventerprisek9-mz.124-2.T, I download only at 300KB/s.

But, now, the cpu load is only 12% with this IOS when I download!

Thanks!

Fabio

Goutam Sanyal Fri, 02/22/2008 - 22:07

hi,

ADSL,RJ-11C,straight-through & WIC-1ADSL this is the interface - right!

As per my concern there is no such problem with your router.

For the "sh processes cpu his"

Basically as per cisco the thumb rule is as follows to monitor the CPU utilization.

The Y-axis of the graph is the CPU utilization.

The X-axis of the graph is the increment within the period displayed in the graph; in this instance, it is the individual minutes during the previous hour. The most recent measurement is on the left end of the X-axis.

The top two rows, read vertically, display the highest percentage of CPU utilization recorded during the increment.

Also please try to run the “ debug packet” followed by “terminal monitor”

You can further visit to know the details of the process:

http://cisco.com/en/US/products/sw/iosswrel/ps1828/products_tech_note09186a00800a65d0.shtml#processes

Thanks

Goutam

jaxel_rulez Sat, 02/23/2008 - 00:47

Hi,

i have run "debug packet" followed by "terminal monitor", the console say "% Use "logging console" instead"... i have try this command (under conf t) but nothing is changed... it's don't produce output...

I suppose that there is a new feature in this IOS that limits the bandwidth of the interface ATM... but I don't understand what...

Thanks,

Fabio

jaxel_rulez Sat, 02/23/2008 - 01:29

Hi,

I try this command, but there isn't output...

Also in my opinion the normal way Cisco IOS features can't limit the bandwidth...

however, if I mount al ios 12.3(10) enterprise base I download at 850KB/s, if i mount a 12.4(2)T advanced enterprise I download at 300KB/s....

Is it possible that I must upgrade the firmware of the wic-1adsl?

Thanks!

Fabio

Goutam Sanyal Sat, 02/23/2008 - 01:52

Hi,

As per you its very strange that after mounting the 12.3(10) enterprise base IOS, your are getting a good response with 850KB/s. But if you go with 12.4(2)T advanced enterprise, your are not getting the same.

Please check the capability IOS for your router. :)

Pls rate if it helps U!!!

Goutam

jaxel_rulez Sat, 02/23/2008 - 02:29

I have checked the capability IOS for my router on http://tools.cisco.com/ITDIT/CFN/Dispatch?act=featSelect&task=init

I have the same problem of limited bandwidth with this ios image:

c2600-spservicesk9-mz.124-7

c2600-entservicesk9-mz.124-12

c2600-advsecurityk9-mz.124-3

I have tested also 12.3(12) ADVANCED SECURITY and I haven't this problem...i download at 800...

I suppose that a feature introduced on 12.4 ios...

Thanks!

Fabio

Goutam Sanyal Sat, 02/23/2008 - 02:41

Hi

Cheers ;)

If solved then close the case :)

Best of Luck & have a erroe free N/W :O

Goutam

jaxel_rulez Sat, 02/23/2008 - 02:54

Hi,

ehm...exceuse me, i don't understand the last phrase "Best of Luck & have a erroe free N/W :O "

I don't solved the problem because I want run a ios 12.4 advanced enterprice...

Thanks,

Fabio

josejames Mon, 02/25/2008 - 14:53

Try updating the firmware of the ADSL wic, you should be able to get the instructions and firmware from cisco's ftp site.

jaxel_rulez Mon, 02/25/2008 - 16:05

Hi,

sorry, I don't find the url for download the firmware of wic adsl...

My firmware version is 3.8131, it isn't the lastest?

Thanks,

Fabio.

jaxel_rulez Wed, 02/27/2008 - 15:40

I have test more IOS, if I use a 12.3 Advanced Enterprise the router work fine, if I use 12.3T, 12.4 or 12.4T Advanced Enterprise, the download is limited at 300KB/s...

What is the problem?

Thanks

Paolo Bevilacqua Wed, 02/27/2008 - 16:58

The problem (as you have found and demonstrated) is for people that wants or need to use 12.3T or later, code is seriusly broken performance-wise, and chances are, it will never be fixed, as both router and card are EOS.

Paolo Bevilacqua Thu, 02/28/2008 - 03:58

Well is not that it doesn't work, it is that as you've found, the performances are poor.

This can be due to a bug but as I said above, due the products being EOL, chances are it will not be fixed. I hope to be wrong however.

jaxel_rulez Tue, 03/04/2008 - 00:06

I have noticed that the Board Revision of my wic adsl is A0, but there are other version with Board Revision B0 or C0, is it possible that I should use a different version of wic adsl?

What are the difference among the different Board Revision?

Thanks.

Fabio

Paolo Bevilacqua Tue, 03/04/2008 - 02:27

According to cisco, the hardware revision never makes a difference and the number is due to the normal improvement of manufacturing.

Actions

This Discussion