cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2441
Views
0
Helpful
9
Replies

EIGRP adj over ethernet sub ints using IP unnumbered

d-fillmore
Level 2
Level 2

Hi - I'm trying to run EIGRP to advertise 2 networks between a pair of routers. The networks to be advertised are (for the purposes of this test) on Loopback 0 on each router. The two routers are connected back to back over fastethernet sub-interface f0/0.100.

They can form an adjacency, but this soon drops and is immediately reformed. No routes are passed.

Here's the relevant config and show commands. Does anyone know how I can get this to work?

Many Thanks in advance

interface Loopback0

ip address 10.10.10.10 255.255.255.0

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip unnumbered Loopback0

!

router eigrp 87

network 10.10.10.0 0.0.0.255

no auto-summary

!

R1#sh ip eigrp neigh

IP-EIGRP neighbors for process 87

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 20.20.20.20 Fa0/0.100 13 00:01:01 1 5000 2 0

R1#

R1#

R1#sh ip ro

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Loopback0

R1#

R1#

R1#

*Feb 22 11:20:27.303: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 87: Neighbor 20.20.20.20 (FastEthernet0/0.100) is down: Interface Goodbye received

*Feb 22 11:20:31.703: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 87: Neighbor 20.20.20.20 (FastEthernet0/0.100) is up: new adjacency

R1#

R2#

!

interface Loopback0

ip address 20.20.20.20 255.255.255.0

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip unnumbered Loopback0

no snmp trap link-status

!

router eigrp 87

network 20.20.20.0 0.0.0.255

no auto-summary

!

R2# sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Loopback0

R2#

R2#sh ip eigrp neig

IP-EIGRP neighbors for process 87

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.10.10.10 Fa0/0.100 14 00:00:14 1 5000 1 0

R2#

R2#

9 Replies 9

Tarek
Level 1
Level 1

The ip addresses on both routers interface FastEthernet0/0.100 are not on the same subnet.

The point to point sub-interface FastEthernet0/0.100 on R1 and R2 should be on the same subnet.

You can can do the following on R2.

int loopback 1

ip address 10.10.10.11 255.255.255.0

Interface FastEthernet0/0.100

ip unnumbered Loopback1

router eigrp 87

network 10.10.10.0 0.0.0.255

network 20.20.20.0 0.0.0.255

no auto-summary

The EIGRP adjacency will flap even when the loopbacks are placed in the same subnet (if u r using unnumbered interfaces)

You can see from your sh ip eigrp neighbors output that there are packets queued for the neighbor and it is not receiving reliable packets from it

I seem to have read somewhere about this problem but not able to recall.. Lets see if somebody else has an answer for this

Narayan

Dominic

I have not used ip unnumbered on Ethernet subinterfaces but I have used unnumbered on point to point serial and I believe that they operate the same way. The unnumbered feature works around the normal requirement that neighbors be in the same subnet. I therefore think that the concern of Tarek about different subnets is not a real problem here.

I believe that Narayan makes a good observation about the queuing of packets and that indicating some problem. Am I correct in understanding your post that the routers are directly connected back to back (no switch in the middle to do trunking)? I wonder if it would work better if you changed the interface configuration slightly and made VLAN 100 the native VLAN? Or could you put a switch into the situation and connect the routers via the switch?

HTH

Rick

HTH

Rick

Thanks for your responses guys.

The routers I'm currently testing with (1841s) are conected back to back with a Xover cable. I did however try it with a pair of 2600s connected through a 3550 with a similar config - both router interfaces trunking and both switchports trunking.

I get odd results if I try OSPF instead of EIGRP, the routing process never starts to try to form an adjacency.

I'll try it without using any trunking at all and see if it works.

Cheers, Dom

d-fillmore
Level 2
Level 2

I have tried it using 100 as the native VLAN on the switch and routers in my lab (2600s & 3550) and it no different. Doesn't even form an adjacency of any sort now.

What I have noticed is a large number of unknown protocol drop error messages, which have obviously built up over the weekend;

R2#sh int f0/0

FastEthernet0/0 is up, line protocol is up

Hardware is AmdFE, address is 000c.85c1.e6c0 (bia 000c.85c1.e6c0)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:10, output 00:00:08, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

63867 packets input, 6049206 bytes

Received 63867 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

30421 packets output, 3082081 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

8546 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Have just found this ereror message which you get on a 4500 switch if you enable ip unnumbered on a non point-to-point interface;

"Warning: dynamic routing protocols will not work on non-point-to-point interfaces with IP

unnumbered configured."

I'm guessing it's the same for routers as well :(

configure the fastethernet interface as a P2P network while using unnumbered with OSPF

int fa 0/0

ip ospf network point-to-point

ip unnumbered loopback 1

Let us know how it goes

Narayan

Dominic

It has always been a restriction of ip unnumbered by Cisco that it worked on point to point interfaces. For a long time that restriction meant that ip unnumbered worked on serial interfaces but not on LAN interfaces (such as FastEthernet). Then Cisco extended the function of ip unnumbered so that it would operate on VLAN subinterfaces of LAN interfaces. But it still does not work on the main (physical) interface. Narayan's suggestion is creative but it does not turn fa0/0 into a point to point interface and I believe that ip unnumbered will not work in the manner that he suggests.

Going back to your original post where the attempt with unnumbered was on subinterfaces where unnumbered may work can you confirm whether there was connectivity? Were you receiving CDP information from the neighbor on that subinterface?

If you go back to the configuration of the original post I wonder what debug would show for eigtp adjacency?

Another thought is that support for unnumbered on LAN subinterfaces was a fairly recent extension within IOS (the doc that I looked at says 12.3(4)T was the original implementation. Are we sure that the routers are running code that supports this feature?

HTH

Rick

HTH

Rick

Jonn cos
Level 4
Level 4

Dear All,

I am currently preparing for my CCIE. I consider netpro to be the most valuable resource for it. I was looking for any issues related with eigrp and ip unnmbered and came around this one. Although its very old, i was able to find the solution. (real fast :-)). Kindly correct me if i did anything wrong and also let me know if my solution and diagnosis is correct.

R1 fas0/0.100 gets an eigrp packet from 20.20.20.20. In ip unnumbered, the restriction for same subnet is loose so it forms the adjacency almost immediately. When time comes to SEND packet to 20.20.20.20, this what R1 is facing

*May  9 03:47:09.167: IP: s=10.10.10.10 (local), d=224.0.0.10 (FastEthernet0/0.100), len 60, sending broad/multicast
R1#
*May  9 03:47:10.347: IP: s=10.10.10.10 (local), d=20.20.20.20 (FastEthernet0/0.100), len 40, sending
*May  9 03:47:10.355: IP: s=10.10.10.10 (local), d=20.20.20.20 (FastEthernet0/0.100), len 40, encapsulation failed

R1 is not able to reach 20.20.20.20 !! . And thus the adjacency fails. If at both ends, i give static routes to each other loopbacks, adjacency forms successfully and routing updates are exchanged.

R1(config)#ip route 20.20.20.20 255.255.255.255 fa 0/0.100

R2(config)# ip route 10.10.10.10 255.255.255.255 fas0/0.100

now everything works fine.

Pls let me know if this solution is correct

Hi John,

Thanks for taking the time to look into this. This was for a network I was designing some time ago whih has since been implented but yes your solution should work.

Cheers, Dom

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card