Trunk Port

Unanswered Question
Feb 23rd, 2008

May i know how to enable the trunk port to let to vlan of cisco switch 2950 to communicate with the vlan of cisco switch 3950? If possible, please provide the commands. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
lamav Sat, 02/23/2008 - 10:39

By default, switch ports that are configured as trunk ports allow traffic from all configured vlans, unless you specifically prune the traffic.

You could use the "switchport tunk allowed vlan 1,2,5,6...etc" to specifically allow traffic from certain vlans. Otherwise, all traffic from all vlans is allowed on the trunk port.

This is a sample confgiuration

interface fastethernet0/1

description Trunk_Port

switchport

switchport mode trunk

switchport trunk encapaulation dot1q

no shutdown

Read this:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2900xl_3500xl/releasesa4/eesoftconfig/masctrnk.html#wp3544

HTH

Please rate this post if you found it helpful.

Victor

ssweehin@gmail.com Sat, 02/23/2008 - 22:48

If i only want the vlan 501 (cisco switch 2950) to communicate with vlan 601 (cisco switch 3950) and vice versa. Do i need to go both of the switches to issue the command below or only 1 of switch will do? And each of the switches has at least 3 vlans. Will it affect all of the vlans inside after issue the command? What is the meaning of "switchport trunk encapsulation isl"? If i put other name after encapsulation like "encapsulation A", "encapsulation B" or "encapsulation C"?

Switch(config)# interface fa0/1

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation isl

Switch(config-if)# end

aijaz802 Sat, 02/23/2008 - 23:02

Hi,

Here are the steps, i hope it will give u help...

You can't communicate with any devices from vlan 501 to devices in vlan 601, until unless you put a layer-3 switch/router between them.

You need to add the trunk commands on both the switches and on trunk ports.

By default a trunk will carry all the vlans, until unless you allowed only few with the command "switchport trunk allowed vlan 1,2,3"

Switchport trunk encapsulation isl or dot1q... isl/dot1q is the trunking protocol thru which two devices communicate about vlan information...you can't use A, B or C..it wont take this option...

Pls. rate this if it helps...

*aijaz*

To communicate with different vlans u need to have a router for doing inter vlan routing.

pascal.coyles Mon, 02/25/2008 - 11:18

Hi,

A 2950 doesn't support ISL

I do not know of a 3950 switch.

If you really want VLAN 501 traffic to mix with VLAN 601 without routing (what is not a nice thing to do), you can make a configuration as follows:

Switch 1

switchport mode access

switchport access vlan 501

Switch 2

switchport mode access

switchport access vlan 601

Just connect these 2 port together and the 2 VLANs will be able to communicate with eachother. This is because access ports aren't VLAN tagged.

Alternatively you can create a trunk between both switches, encapsulation dot1q, on one side native vlan 501 and on the other side native vlan 601.

But again, it's not a nice thing to do.

Best regards,

Pascal

ssweehin@gmail.com Mon, 02/25/2008 - 18:34

"Connect these 2 port together" means using a cable to plug in into 1 of the port of the both Vlans right?

ssweehin@gmail.com Sat, 02/23/2008 - 23:00

If i only want the vlan 501 (cisco switch 2950) to communicate with vlan 601 (cisco switch 3950) and vice versa. Do i need to go both of the switches to issue the command below or only 1 of switch will do? And each of the switches has at least 3 vlans. Will it affect all of the vlans inside after issue the command? What is the meaning of "switchport trunk encapsulation isl"? If i put other name after encapsulation like "encapsulation A", "encapsulation B" or "encapsulation C"?

Switch(config)# interface fa0/1

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation isl

Switch(config-if)# end

bvsnarayana03 Sun, 02/24/2008 - 00:55

How to classify pkts from different vlans & identify them. For this purpose, switch adds a VLAN id specific to each vlan. It is this vlan id that helps the switch to recognise which pkts belong to which vlans.

ISL & dot1q are supported encapsulation types. ISL is cisco propreitary & other is open standard.

Yes u ned to give the trunking & encapsulation commands on both sides of trunk.

If u want only 1 vlan say x to propagate the trunk & rest of vlans are local to switch & ned not flow to multiple switches then issue this command on your trunks:

switchport trunk allowed vlan x

hope that helps.

pls rate all helpful posts.

Actions

This Discussion