strange inside-outside-inside PAT problem

Unanswered Question
Feb 24th, 2008

I have a router with three interfaces serving two (related) companies. Each company has their own LAN interface but both share the WAN interface even though each company has a different public IP. I've set up standard NAT and incoming PAT rules and everything works just fine... EXCEPT I cannot get company1 to communicate to company2 if they use their external WAN IPs...

here's a sanitized snipped of the config:

interface FastEthernet0/0

description WAN

ip address 123.45.67.2 255.255.255.240

ip address 123.45.67.3 255.255.255.240 secondary

ip nat outside

!

interface FastEthernet0/1

description LAN1

ip address 10.0.0.1 255.255.255.0

interface FastEthernet0/2

description LAN2

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip route 0.0.0.0 0.0.0.0 123.45.67.1

ip nat inside source static tcp 192.168.0.8 25 123.45.67.2 25 extendable

ip nat inside source static tcp 10.0.0.16 25 123.45.67.3 25 extendable

If I try to connect to port 25 of company1's public IP from an internal LAN IP of company2 it doesn't work. I can connect internal 10.0.0.x and 192.168.0.x just fine, but using the other company's public IP doesn't work.

I'm guessing it's because I'm doing double NAT, but I don't know how to fix it.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion