MGCP protocol operation ?

Unanswered Question
Feb 24th, 2008

Hi Netpros,

I have a situation when sometimes an inbound call attempt is dropped before the connection is established. For example ... if I called a number on my company from a mobile or public phone .. the company phone rings once and dies before I get the chance to answer it.

We have call manager 4.1 and using 2821 configured as MGCP gateways (Primary and backup) using PRI. Both gateways show registration with Call manager ok when using show ccm. Unfortunately I have not been able to reproduce the issue and at the same time debug isdn q931. Any advice or links that could help me pinpointing this issue is much appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
gogasca Sun, 02/24/2008 - 21:07

Reproduce the issue.

Detailed CCM traces

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080094e89.shtml#subpro1

Exact CCM version

Exact Phone model and firmware

Shared lines?

Same Number?

Same B channel?

debug isdn q931

debug mgcp packet

Timestamps

IOS version

Check DSPs integrity.

http://www.cisco.com/en/US/products/hw/modules/ps2617/products_tech_note09186a008039c316.shtml

pharden Mon, 02/25/2008 - 06:59

Is there an ATA involved? We have that issue with incoming calls going to An ATA first. two rings and then busy. I have to reset the switchport connected to the ATA.

No sure if this is your case.

Fernando_Meza Mon, 02/25/2008 - 19:10

you mean a cisco ATA Analog Telephone adaptor ..? no we don't use this,

Thanks,

Fernando_Meza Mon, 02/25/2008 - 18:57

Thanks,

I opened a TAC and was advised to enabled CCM detailed traces. I am currently waiting for the event to occur and will provide the logs to Cisco TAC.

Cheers,

Fernando_Meza Mon, 02/25/2008 - 18:55

Hi,

Yes it has binded to the loopback interface. But thanks for your comments

Actions

This Discussion