Unified Presence Integration with LDAP

Unanswered Question
Feb 24th, 2008


I am not able to do LDAP integration, I am not finding the users in the U.P. from LDAP, how to solve that?

Is there a sample configuration guide as the administration guide is not really helping me.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
okuehn Sun, 02/24/2008 - 23:18


the LDAP integration works fine. you have to configure an appropriate LDAP profile under "Application/CUPC/LDAP Profile"

there are two important things which can be the cause of your LDAP problem:

1) Bind Distinguished Name (DN)

the DN of the user account used to bind to LDAP, e.g.


2) Search Context

the root of the part of LDAP tree where your user accounts are stored. if you have a more complex structure you can use:


hope it helps, please rate

cheers, oliver

Fady Hwalla Mon, 02/25/2008 - 04:06

I did all these, already the CUCM is integrating with the LDAP (AD) with such configuration, but the U.P. is not.

On the CUCM there is: "Sync Now" button, is there anything like it on U.P.?

okuehn Mon, 02/25/2008 - 08:06

Hi Fady,

you can confirm the following points:

1) "Application/CUPC/LDAP Server"

due to performance problems, use a global catalog LDAP server. therefor use TCP port 3268

2) "Application/CUPC/Settings"

In the directory server type should be "Microsoft Active Directory" selected

regards, Oliver

Fady Hwalla Mon, 02/25/2008 - 23:20

Dear Oliver,

I did point number 1 and point number 2 is already done, but still when I go to: "Users in Profile" and I click on "Add Users to Profile" and I click find, I get 0 users.

Again, is there somewhere a "Sync All" I should click, or what I am doing is fine?



okuehn Tue, 02/26/2008 - 00:22

Hi Fady,

sorry, probably i did misunderstood your issue.

please check wether you have enabled users in CUCM for presence. therefore you have to assign license capabilities under "system/licensing/capabilities assignment"

for full CUPC usage assign both:

1) Enable CUP (Cisco Unified Presence)

2) Enable CUPC (Cisco Unified Personal Communicator)

regards, oliver

Fady Hwalla Tue, 02/26/2008 - 01:33

Dear Oliver,

I have done the 2 points you have told me and still I can not see the users, but when I clicked on the troublsheeter, I saw these:

Unable to connect to Cisco Unified Communications Manager publisher node with address Please verify the publisher address, AXL user-id, and AXL password on the AXL Settings page (fix)

The "Cisco UP Sync Agent" is "Not Running" and when I click on start, it goes back to "Not Running" Mode, why?



okuehn Tue, 02/26/2008 - 02:20

you have to configure an application user in CUCM with appropriate roles.

please ensure that this user is configured as axl in CUPS under "cisco Unified Presence/Security/AXL Configuration" and the passwords matches on pub and CUPS

Fady Hwalla Wed, 02/27/2008 - 08:40

I got help from PDI helpdesk and thanks: CUPS 6.0 Deployment Guide - this document have lots of configurations that was not mentioned in the installation and administration guides of UP.

Your info helped me alot as well. Thanks man




This Discussion