DCR and DFM DB not has same devices number

Unanswered Question
Feb 25th, 2008
User Badges:

Hi Folks!


I've installed, on windows 2003 server, LMS 2.6 with CS 3.0.6 and DFM 2.0.10.


I've syncrhonized DCR with DFM into DFM page, but into DFM I've 316 devices, while in DCR I've 339 devices.


Anybody know how I can sysnc both DB?


Thanks a lot!

Leonardo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Joe Clarke Mon, 02/25/2008 - 09:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This could be a process failure issue, or it may just be a timing issue. To check for the latter, go to DFM > Device Management > Device Selector, and uncheck the " Synchronize with Device Credential Repository". Apply your changes. then re-check the box, and apply again. If all the devices sync with DFM, then you should be okay. If not, you have a process issue either with TISServer, or the low-level DfmServer.

leorob123 Mon, 02/25/2008 - 09:43
User Badges:

Thanks..


what mean this?

> or the low-level DfmServer


on windows services there is a process even stopped and named

"DFM dfmEpm database engine"

It has to be down?


TKS!

Leonardo

Joe Clarke Mon, 02/25/2008 - 09:45
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is a process called DfmServer. This is the EMC process that actually talks to devices.


The EPM database cannot be down. Something is wrong with it. What files do you have under NMSROOT\databases\dfmEpm?

leorob123 Mon, 02/25/2008 - 11:18
User Badges:

there are the dfmEpm.log file, the dfmEpm.db and a folder named orig (inside it there are odbc.tmpl/orig files and the orig db).

Joe Clarke Mon, 02/25/2008 - 11:51
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Shutdown dmgtd, remove dfmEpm.log, and run:


NMSROOT\objects\db\win32\dbsrv9 -f NMSROOT\databases\dfmEpm\dfmEpm.db


Then restart dmgtd, and the EPM database engine should start.

Actions

This Discussion