1841 ROMmon Boot Problems

Unanswered Question
Feb 25th, 2008

Hi there,

I have got an 1841 (adsl) router that is stuck in a boot loop, I have tried changing the 32mb flash card to a known working card , but the problem is still there.

I have attached a bootup trace.

Would a ROMmon upgrade help? Is there a way to upgrade the ROMmon from the ROMmon menu?

Thanks in advance, Steve.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
vaisharm Mon, 02/25/2008 - 07:03

Hi Steve,

How did the problem start initially? The problem is not flash card related. Here are a few things that you can try:

- unplug all the modules and then boot the chassis. If it comes up fine, insert one module at a time.

- if it still fails, change the config register to 0x2142 to ignore the startup config.

rommon>confreg 0x2142


- if the router still does not boot, then reseat the DRAM.

- If still no success, contact TAC for an RMA.


honeyss07 Mon, 02/25/2008 - 07:33

Hi Vaibhav,

Thanks for your reply, the problem initally occured after a power reset, the unit was working fine then never came back up again after the power reset.

I've tried with the ADSL WIC in and out,

I've just popped the case off but there is no DRAM installed to reseat, changed the confreg to ignore the startup config, but still no joy.

Looks like i'll have to contact TAC.

Thanks again for your help,


PS One thing I forgot to mention is the link and 100 LED on FE0/0 are permanently on? dont know if this is relevant.


This Discussion