Upgrading flash and memory on 2620xm router

Unanswered Question
Feb 25th, 2008

hi,

I have a 2620xm with 16Mb flash and 96Mb RAM.

I would upgrade this router to 48Mbflash and 256Mb RAM.

I've read some bulletins about this upgrade but I dont' understand which spare part I have to buy.

Anyone can help me?

Thanks in advance

Antonio

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Mon, 02/25/2008 - 13:35

Antonio

The part numbers that I can find on the Cisco site are: MEM2600XM-128U256D 128 to 256MB DRAM factory upgrade for Cisco 2600XM

MEM2600XM-32U48FS 32 to 48 MB Flash Factory Upgrade for the Cisco 2600XM

But they appear to be for upgrading memory from 128 to 256 and upgrading flash from 32 to 48. I am not clear that Cisco has the parts any more to upgrade your router.

I did find some references for upgrades from some sources on the Internet. Here are some links:

http://www.memoryx.net/mem2600xm32fs.html

http://www.memoryx.net/mem2600xm128d.html

I am sure that there are other sources that can provide this.

HTH

Rick

antonio.dinapoli Tue, 02/26/2008 - 03:24

Relating to RAM upgrade, do you know what version of ROMMON do I have to buy to work with 256Mb RAM?

MEM2600XM-128DBOT= or BOOT-2600XM-256=

I dont' understand if i can buy:

- n.1 MEM2600XM-128DBOT= and n. 1 MEM2600XM-128D=

or

- n.2 MEM2600XM-128D= and n.1 BOOT-2600XM-256=

Thanks

Antonio

vaisharm Tue, 02/26/2008 - 19:38

Hi Antonio,

In order for a 2620XM ro recognize 256MB DRAM, you need BOOTROM version 12.2(8r) and IOS version 12.3(11)T. For upgrading from 96MB to 256MB DRAM, you would need two 128MB DRAM DIMM and a bootrom w/12.2(8r) if your current bootrom is lower then this version.

Basically, your current 96MB DRAM can not be used as the 2620XM motherboard has 2 DRAM slots only and you would need 2 x 128MB DIMMs.

Here are the part numbers:

1. MEM2600XM-128D= 128 MB DIMM DRAM for the Cisco 2600XM Series

2. MEM2600XM-128DBOT= 128 MB DRAM and Boot ROM for Cisco 2600XM Series

(This is required if your current bootstrap code is lower then 12.2(8r). Upgrade the IOS to atleast 12.3(11)T aswell).

Upgrading System Memory, Internal Flash, and Boot ROM in Cisco 2600 Series Routers

http://www.cisco.com/en/US/partner/docs/routers/access/2600/hardware/installation/notes/2600mem.html

New Memory Capacity on the Cisco 2600XM Series Multiservice Router

http://www.cisco.com/en/US/partner/prod/collateral/routers/ps259/prod_bulletin0900aecd801e3d53.html

HTH, rate if it does.

~Vaibhav

Actions

This Discussion