Unanswered Question
Feb 25th, 2008


Does anyone knows why i'm getting this output from a 836 Cisco?

rommon 1 > boot c836-k9o3y6-mz.123-14.T7.bin

an alternate boot helper program is not specified

(monitor variable "BOOTLDR" is not set)

and unable to determine first file in bootflash

loadprog: error - on file open

boot: cannot load "c836-k9o3y6-mz.123-14.T7.bin"

rommon 2 >

It refused to load from flash.

I make the whole tftpdnld procedure with 3 different ios

Check this out also

(i'm givving) rommon 2 > boot flash:c836-k9o3y6-mz.123-14.T7.bin

(and getting) Checksum failed on c836-k9o3y6-mz.123-14.T7.bin

Expected checksum: f411, calculated checksum: a28b

open: file "c836-k9o3y6-mz.123-14.T7.bin" not found

open(): Open Error = -1

loadprog: error - on file open

boot: cannot load "flash:c836-k9o3y6-mz.123-14.T7.bin"

Notes: The image its loaded propriate in the flash with the correct file size on it

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
htarra Fri, 02/29/2008 - 14:58

type this in your Cisco 836 ADSL :

rommon >boot flash: c836-k9o3y6-mz.123-14.T7.bin

rommon >reload

Then you're going to be in a normal mode,

in this point, please type:

#config t

(config)#no boot system

(config)#boot system flash: c836-k9o3y6-mz.123-14.T7.bin


#copy run start

#sh ver

Here just check at the end if the configuration register is Ox2102

if not just type:

#config t

(config)#config-register 0x2102


#copy run start

At the end restart the Cisco 836 ADSL :


Paolo Bevilacqua Fri, 02/29/2008 - 16:29

He can't enter any of the IOS commands you're suggesting, precisely because the router fails to boot IOS.

ptsomokos Sun, 03/02/2008 - 08:43

Thanks for your answer.

The problem was slightly different.

I tried 3 IOS and while the flash was 12MB probably was too mush for it.

Thats why the screens I posted

I tried the first one 7.5MB with xmodem and everything goes fine.

The initial problem was that someone probably delete the ios and the router fell on rommon mode

Goutam Sanyal Fri, 02/29/2008 - 21:05


With the addition with Paolo, I'd like to suggest you to tri with "boot slot0:". If till you are facing the same problem, try to upload the IOS via Xmodem.



Pls rate if it helps u!!!


This Discussion