Juniper and Cisco MPLS MTU

Unanswered Question
Feb 25th, 2008

Hi,

I would like to know the equivalent command in Juniper for "mpls mtu" in Cisco. I made L3 MPLS VPN up between Juniper and Cisco and ping is working fine. But im not able to send packets greater than 1488 with DF bit set. I suspect problem could be because of MPLS MTU mismatch between the two. Is there any specific command available in JUNOS similar to Cisco or Shall we need to change the L2 MTU of the physical interfce only (im afraid changing the L2MTU at Juniper will have any problem in OSPF neighborship).

Thanks in Advance..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
guruprasadr Mon, 02/25/2008 - 21:13

HI ArunKumar, [Pls Rate if HELPS]

Max MTU Size supported on Juniper for both MTU / System MTU is 1500 only.

I would recommend not to make any changes in the Juniper Box.

Try modifying the MTU values over the L2 path. Any mis-match of MTU values over the L2 path will have such impacting scenario's

Make sure in L2 Path the VLAN Tag is added as "4" bytes over the Packet Header.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

arun kumar Tue, 02/26/2008 - 05:06

Hi Guru,

Im able to change the MTU size in Juniper box. In Juniper the default MTU is showing as 1514 bytes. Max i can able to set till 9000 bytes. I ve made L3 MPLS VPN up with Cisco and end to end ping is working fine. But im not able to ping with data size more than 1488 bytes. For L2 MPLS VPN, the max data size is 1470 bytes. I tried changing the L2MTU of Juniper but OSPF went down with Cisco. The intermediate switch is configured with Jumbo Frame size so i dont have any issue in L2 Path. I would like to configure the MPLS MTU ciommand in Juniper similar to Cisco so that Labelled packets will flow through it.

william.caban Tue, 02/26/2008 - 07:14

Hi,

It is my understanding that MPLS (in Cisco) will use the MTU defined at the interface and/or system.

I alway use "ip tcp path-mtu-discovery" in the platform that it is supported. The following are outputs, the first from a 7200 (no mtu set) the second from a 7600 (with MTU set at interface and vlan)

PE1#sh mpls interfaces fastEthernet 0/0 detail

Interface FastEthernet0/0:

IP labeling enabled (ldp):

Interface config

LSP Tunnel labeling not enabled

BGP tagging not enabled

Tagging operational

Optimum Switching Vectors:

IP to MPLS Turbo Vector

MPLS Turbo Vector

Fast Switching Vectors:

IP to MPLS Fast Switching Vector

MPLS Turbo Vector

MTU = 1500

PE2#sh mpls interfaces vlan 100 detail

Interface Vlan100:

IP labeling enabled (ldp):

Interface config

LSP Tunnel labeling not enabled

BGP labeling not enabled

MPLS operational

MTU = 9216

Also there is a specific command to override the MPLS MTU at interface level

PE2(config-if)#mpls mtu ?

<64-9000> MTU (bytes)

override Override mpls mtu maximum of interface mtu

HTH

-William

rmilor Tue, 02/26/2008 - 13:38

This command sets the MPLS mtu on the Juniper.

set interfaces "xxx" unit 0 family mpls mtu

I usually set the mtu to max 9192 on the Juniper and then set the interface mtu to 9192 and the IP MTU to 9178 on the Cisco.

Hope this helps.

arun kumar Tue, 02/26/2008 - 20:32

Hi

Should the Interface MTU be set to the same value of MPLS MTU config. Because my juniper router throws the following error when i tried to configure the MPLS MTU. i will not be able to change the Interface MTU in juniper as my IGP goes down with Cisco.

[email protected]# set ge-1/3/0 unit 0 family mpls mtu 1550

[edit interfaces]

[email protected]# commit check

[edit interfaces ge-1/3/0 unit 0 family]

'mpls'

Family MTU is too large relative to device MTU

error: configuration check-out failed

[edit interfaces]

[email protected]#

thanks in advance

Actions

This Discussion