3750 system crash Version 12.2(35)SE5

Unanswered Question
Feb 26th, 2008


we have a 3750 and the switch rebooted itself.

the following is the system crash info, anyone seen this ?

00:02:12: %PLATFORM-1-CRASHED: System previously crashed with the following message:

00:02:12: %PLATFORM-1-CRASHED: Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(35)SE5, RELEASE SOFTWARE (fc1)

00:02:12: %PLATFORM-1-CRASHED: Copyright (c) 1986-2007 by Cisco Systems, Inc.

00:02:12: %PLATFORM-1-CRASHED: Compiled Thu 19-Jul-07 19:15 by nachen

00:02:12: %PLATFORM-1-CRASHED:

00:02:12: %PLATFORM-1-CRASHED: Debug Exception (Could be NULL pointer dereference) Exception (0x2000)!

00:02:12: %PLATFORM-1-CRASHED:

00:02:12: %PLATFORM-1-CRASHED: SRR0 = 0x0099D118 SRR1 = 0x00029230 SRR2 = 0x00648994 SRR3 = 0x00021000

00:02:12: %PLATFORM-1-CRASHED: ESR = 0x00000000 DEAR = 0x00000000 TSR = 0x8C000000 DBSR = 0x00800000

00:02:12: %PLATFORM-1-CRASHED:

00:02:12: %PLATFORM-1-CRASHED: CPU Register Context:

00:02:12: %PLATFORM-1-CRASHED: Vector = 0x00002000 PC = 0x0099A2C0 MSR = 0x00029230 CR = 0x93555039

00:02:12: %PLATFORM-1-CRASHED: LR = 0x0099D140 CTR = 0x006D1AD4 XER = 0xC0000040

00:02:12: %PLATFORM-1-CRASHED: R0 = 0x0099D140 R1 = 0x01D35060 R2 = 0x00000000 R3 = 0x00000000

00:02:12: %PLATFORM-1-CRASHED: R4 = 0x00000005 R5 = 0x020C2ED4 R6 = 0x00029230 R7 = 0x00000000

00:02:12: %PLATFORM-1-CRASHED: R8 = 0x016D0000 R9 = 0x0000001D R10 = 0xA550BEAD R11 = 0x016C0000

00:02:12: %PLATFORM-1-CRASHED: R12 = 0xA550BEB2 R13 = 0x00110000 R14 = 0x00000000 R15 = 0x00000000

00:02:12: %PLATFORM-1-CRASHED: R16 = 0x01CA08A4 R17 = 0x01CA086C R18 = 0x01CA0000 R19 = 0x01AA0000

00:02:12: %PLATFORM-1-CRASHED: R20 = 0x01AA0000 R21 = 0x00000000 R22 = 0x01CA0000 R23 = 0x00000000

00:02:12: %PLATFORM-1-CRASHED: R24 = 0x01CA08A4 R25 = 0x01CA0000 R26 = 0x00000000 R27 = 0x01CA0000

00:02:12: %PLATFORM-1-CRASHED: R28 = 0x00000000 R29 = 0x01CA0000 R30 = 0x00000000 R31 = 0x00000000

00:02:12: %PLATFORM-1-CRASHED:

00:02:12: %PLATFORM-1-CRASHED: Stack trace:

00:02:12: %PLATFORM-1-CRASHED: PC = 0x0099A2C0, SP = 0x01D35060

00:02:12: %PLATFORM-1-CRASHED: Frame 00: SP = 0x01D35070 PC = 0x01CA0000

00:02:12: %PLATFORM-1-CRASHED: Frame 01: SP = 0x01D350D0 PC = 0x0099D0F0

00:02:12: %PLATFORM-1-CRASHED: Frame 02: SP = 0xFFFFFFFF PC = 0x0099A198

00:02:12: %PLATFORM-1-CRASHED:

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Danilo Dy Tue, 02/26/2008 - 07:41


I can't figure out what could cause the crashed. Did you execute any commands before it crashed? FYI, the version of IOS you have is notorious for crashes and reloads. If you can't find the root cause of the crash, I suggest you update your IOS



ciscograyaw Tue, 02/26/2008 - 10:59

For our 3750s, we have locked in on 12.2(25)SEE4. Newer versions have notorious crash problems, a lot of problems with DHCP snooping and source guard, PoE bugs, and more. 12.2(25)SEE4 isn't perfect - but it's by far the least problematic that we've come across.

hobbe Wed, 02/27/2008 - 08:22

I tried to use the same version (12.2.35) but still have not found any that is stable enough to be used in production environment

so I also use the 12.2.25 see version,

one even crached when I tried to set an ip address on vlan1.

This is a realy crappy thing for the 3750 series. it could have been real nice, but the ios isnt stable. I dont know why they do not test it until it works.

adam.sellhorn Wed, 02/27/2008 - 08:33

Just FYI, I had the same issues on my 3750 stack until I went 12.2(44)SE. Haven't had an issues since... Have you tried this release yet?

ciscograyaw Wed, 02/27/2008 - 09:46

I admit we're a little gun-shy here after the bugs in 35, 37, and 40. The one that really cripples us are the dhcp snooping bugs - 35 likes to forget its binding database so everyone loses connectivity, 37 likes to stop accepting new entries for no easily explainable reason and had a PoE bug (which I think they fixed in the last rev) to boot, and by the time we got around to start full-tests on 40, 44 had come out. Yeesh.

davidharan1 Sat, 03/07/2009 - 05:36

what was your specific cause? a random crash or some command?

i'm experiencing crashes, 'Debug Exception (could be NULL pointer dereference), etc, as a result of changes to layer 3 interfaces (copper and fiber / sfp ports). i.e. any configured changed that brings the port up (no shut, change of negotiate settings).

the stack master then crashes immediately and consistently.

i'm using Advanced IP Services, 12.2(40)SE, in a stack with 1 x 3750E-48TD and 4 x 3750G-48TS.

glen.grant Sat, 03/07/2009 - 05:53

Think we run the 12.2.35 versions . I don't remember any 3750 crashing in all the time we have had them. They are funky as heck trying to get them to all upgrade correctly but besides that they have reasonably stable.


This Discussion