3550 - How do you delete a subdir in Flash?

Unanswered Question
Feb 26th, 2008
User Badges:

Hi, I successfully updated the IOS on a 3550 but cannot delete the dir that housed the old IOS.

Here's what I tried:

Switch#rmdir c3550-i9q3l2-mz.121-22.EA4

Remove directory filename [c3550-i9q3l2-mz.121-22.EA4]?

Delete flash:c3550-i9q3l2-mz.121-22.EA4? [confirm]

%Error Removing dir flash:c3550-i9q3l2-mz.121-22.EA4 (Unknown error 93)


I had deleted the files out of the dir. I tried remarking the folder in a number of different ways:

Switch#delete flash:c3550-i9q3l2-mz.121-22.EA4/


Thank you for any help you can offer,

Troy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
ciscograyaw Tue, 02/26/2008 - 15:31
User Badges:

Well, the quick-n-dirty way would be to re-format the flash: and re-save configs and IOS. I just love "Unknown errors", although my memory seems to say I'd seen this once long, long ago... looking through my notes, although I thought that was related to the directory used to be a modular IOS which doesn't apply here....


Have you tried deleting the directory from ROMMON?

troyheiss Wed, 02/27/2008 - 08:07
User Badges:

I haven't tried yet from ROMMON. I'll check it out.


Thank you,

Troy

glen.grant Tue, 02/26/2008 - 16:34
User Badges:
  • Purple, 4500 points or more

You don't have to get rid of all the individual files.

This gets rid of a directory and everything in it.

delete /force /recursive flash:

troyheiss Wed, 02/27/2008 - 08:06
User Badges:

That cmd will remove files, but not the directory. No luck on removing the old dir.


Still trying,

Troy

glen.grant Wed, 02/27/2008 - 09:38
User Badges:
  • Purple, 4500 points or more

It does remove a directory have used it many times getting rid directories that contain ios files. If it didn't work in your case i don't know why .

troyheiss Wed, 02/27/2008 - 09:41
User Badges:

Maybe operator error on my part! ; )

Yeah, I don't get it...one of many things.


Thank you for your help,

Troy

CSCO12710946 Wed, 06/01/2016 - 09:10
User Badges:

All you have to do to get rid of a directory when in ROMMON mode is use the command recommended by the gent above; however, you must include the directory name, as following:

delete /force /recursive flash:[directory name]

If you don't include the directory name, it won't work.


Louie



Actions

This Discussion