Help configuring EVM-HD-8FXS/DID

Unanswered Question
Feb 26th, 2008


Do you a sample configuration for EVM-HD-8FXS/DID? I have analog phones connected to this device but i don't hear the dial-tone.

Please help.

Thank you,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
rickyhadlocon Wed, 02/27/2008 - 02:17

Thanks for your help. Regarding your question, yes i have a PVDM2-48 currently installed in my 2851.

Paolo Bevilacqua Wed, 02/27/2008 - 04:32

Ok, then unless you have all the DSPs taken for other voice ports, you should have dialtone by default.

Are you using the recommended blackbox patch panel w/ RJ21 cable ?

You can check what the FXS port does with "debug vpm signal" and "term mon".

rickyhadlocon Wed, 02/27/2008 - 06:03

Thanks for your reply. How do i know i already exhausted all my DSP resources? I'm not using the recommended blackbox patch panel.

Paolo Bevilacqua Wed, 02/27/2008 - 06:43

If the voice-ports for the module appears in configuration, there is no DSP issue.

The other possibility is that the patch panel you're using is not cabled correctly. The pinout is in the network module documentation.

rickyhadlocon Wed, 02/27/2008 - 07:05

All the voice-ports are appearing in the configuration. We will double-check if the patch panel is cabled correctly.

Thank you.

rickyhadlocon Thu, 02/28/2008 - 02:57

You are correct, the patch panel was not cabled correctly. Now, i can hear the dial-tone and can make calls to other analog phones connected to the same EVM-HD-8FXS/DID. However, when i dial an ip phone from the analog phone i always get a busy tone. I already configured a dial-peer voice XXX voip to route calls to the CM but i got the same result.

Am i still missing some configurations in my router?

Paolo Bevilacqua Thu, 02/28/2008 - 03:41

Are you using h323 or mgcp with cm? Is this router configured as a gateway of some sort into cm ?

rickyhadlocon Thu, 02/28/2008 - 14:26

Thanks for your reply. The router is configured as the wan router and the voice gateway at the same time. Also, the router is using H323.

Paolo Bevilacqua Thu, 02/28/2008 - 14:48

Under the voip dp, configure codec g711u to begin with. Then if you need to use g729, there is chapter about that in CM's documentation.

rickyhadlocon Thu, 02/28/2008 - 17:47

I already had that configure before. Below is my voip dp:

dial-peer voice 101 voip

preference 1

destination-pattern 9999....

progress_ind setup enable 3

voice-class codec 100

voice-class h323 1

session target

dtmf-relay h245-alphanumeric

no vad

What else am i missing?

Paolo Bevilacqua Fri, 02/29/2008 - 03:29

May be the voice-class has a wrong codec preference. Use fixed g711u, that is usually the best choice.

rickyhadlocon Fri, 02/29/2008 - 06:25

Below is my voice-class configuration:

voice class codec 100

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

Do i need to change anything from the list?

Paolo Bevilacqua Fri, 02/29/2008 - 08:42

Seems ok, still I would try a fixed codec as mentioned above.

Failing that, you need to take traces either on the GW (debug cch323 - warning, can be quite verbose), or on the CCM, unfortunately on the latter I can't help.


This Discussion