copying config info to a new switch

Answered Question

all the interface info? How or where do I paste the info in? I have consoled in. I just not sure how I copy this info to the new switch.

Thanks,

DJ

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 10 months ago

DH

As I said in my post in the other thread you can paste almost all of the interfaces directly from the old switch to the new switch (as long as you verify that the new switch numbers interfaces the same way the old switch did). The major exception if interface fastethernet0/1. This is your primary trunk port on the old switch and in the other thread you indicate that on the new switch the trunk will be on fiber (gig interface I believe). So do not paste the interface fastethernet0/1 into the new switch but take those interface parameters and put them into the interface which will be the trunk on the new switch. I would put these under fastethernet0/1:

switchport access vlan 2

switchport mode access

spanning-tree portfast

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Richard Burts Wed, 02/27/2008 - 08:47

DJ

I am not sure that I understand the first part of your question which asks: all the interface info?

The safe answer is to input (paste or otherwise) config information for each interface that you want to use. (sometimes the default configuration of the interface is sufficient and does not need any special configuration). For example if you have a 48 port switch and you are only going to use the first 24 interfaces (at least for now) then you only need to be concerned with configuration of the first 24 interfaces.

If you are consoled into the switch are you in user mode or in privilege mode?

If in user mode you need to get to privilege mode using the command: enable (and probably the proper password).

If in privilege mode then enter config mode using the command: config t

In config mode you can paste in config commands or you can type in config commands.

One word of advice about pasting in config information. Most terminal emulators can send data more quickly than the router or switch can process it. With short configs it is usually not an issue. But as the size of the config file increases there is a chance that the paste of config will outrun the switch or router. The solution is to configure the terminal emulator to increase the end of line delay. The details of how to do that depend on the particular emulator that you are using.

HTH

Rick

SO, I can copy all the interface interface info form the old back up and pasted it strait into the console in config mode.

so copy this

!

interface FastEthernet0/1

description Connection to

switchport trunk encapsula

switchport mode trunk

duplex full

speed 100

!

interface FastEthernet0/2

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

ect and just paste it? and then what?

DJ

Correct Answer
Richard Burts Wed, 02/27/2008 - 09:38

DH

As I said in my post in the other thread you can paste almost all of the interfaces directly from the old switch to the new switch (as long as you verify that the new switch numbers interfaces the same way the old switch did). The major exception if interface fastethernet0/1. This is your primary trunk port on the old switch and in the other thread you indicate that on the new switch the trunk will be on fiber (gig interface I believe). So do not paste the interface fastethernet0/1 into the new switch but take those interface parameters and put them into the interface which will be the trunk on the new switch. I would put these under fastethernet0/1:

switchport access vlan 2

switchport mode access

spanning-tree portfast

HTH

Rick

lamav Wed, 02/27/2008 - 08:48

Donna:

I've seen your previous posts regarding this effort, so it seems like you're struggling with this.

Perhaps I can help simplify the process...

Taking things logically, if you are going to "copy and paste" a config from one switch to another, you have to:

1. Make sure that the new switch will support the options and features you are going to apply to the new switch. If you are implementing, say, some IPSec features in the old switch, you have to be sure that the new switch will support it. I think you have a pretty basic L2 switch configuration, though. Correct?

2. Make sure that the interfaces map correctly. That's obvious, right? Let's say you have a trunk on "interface gigabitethernet 1/1" on the old switch, well, then, the new switch must have a gigebitethernet port to support that trunk...and then you have to make sure the numbering scheme is the same.

Or maybe the old switch's used a 0/0 numbering scheme, while the new one uses a 0/1 scheme for th efirst port. This is up to you to examine and make sense out of.

As far as copying and pasting itself, it's just like anything else: highlight the text you want to copy, right click and save it to the clipboard, and then right click and paste it to the new switch. Is that what you're asking?

The way to bring up the old switch's configuration is to simply do a "show start" at the switch's privilege exec prompt.

Example: First_floor_Switch# show start

You will then see the entire switch's configuration, interfaces and all.

Has this helped you?

If so, please rate my post.

Thanks

Victor

Actions

This Discussion