Layer 3 Switching

Answered Question
Feb 27th, 2008
User Badges:

Since we have enable layer 3 switching on our two 4506 switches, we have not been able to ping them. Any ideas that may help us resolve this issue.

Correct Answer by wochanda about 9 years 4 months ago

If all you did was type 'ip routing' on the switches, you probably lost your default gateway.


With ip routing disabled, the switch relies on the 'ip default-gateway' command to see how to communicate with other networks.


Once you enable ip routing, we no longer use the 'ip default-gateway' command, but instead look in your routing table to see where to send packets.


To fix this, log into the switch and look for a command looking like this:


ip default-gateway 10.1.1.1


and convert it to this:


ip route 0.0.0.0 0.0.0.0 10.1.1.1

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Mohamed Sobair Wed, 02/27/2008 - 15:01
User Badges:
  • Gold, 750 points or more

Hi,


You mean L3 routing, If you have Inter vlan routing enabled between Vlans, then make sure you gave them a layer-3 IP address.


you should also enable routing globally, with the (Ip routing) command.




HTH

Mohamed

Correct Answer
wochanda Wed, 02/27/2008 - 15:48
User Badges:
  • Silver, 250 points or more

If all you did was type 'ip routing' on the switches, you probably lost your default gateway.


With ip routing disabled, the switch relies on the 'ip default-gateway' command to see how to communicate with other networks.


Once you enable ip routing, we no longer use the 'ip default-gateway' command, but instead look in your routing table to see where to send packets.


To fix this, log into the switch and look for a command looking like this:


ip default-gateway 10.1.1.1


and convert it to this:


ip route 0.0.0.0 0.0.0.0 10.1.1.1

Actions

This Discussion