IPCCE problem with hardphones

Unanswered Question
Feb 28th, 2008
User Badges:

I have an installation of IPCC Enterprise 7.0 with IP IVR. I configured all the systems and everything is working properly, both ICM and IVR. Both scripts are collaborating and the agents receives the variables on the desktop. All these have been tested using IP Communicators. When an agent who is using hard phone (7941), nothing is working. The routing script of ICM fails and goes to the End node. I created a simple script with LAA node and a Skill Group, without sending it to IVR and I have the same symptoms.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cherilynn1030 Thu, 02/28/2008 - 05:39
User Badges:

Do you have the 7941 configured in call manager, for contact center calls?

ageloskapousizis Thu, 02/28/2008 - 06:27
User Badges:

Yes I have configured the phones in CCM. I have enabled the CTI. The hard phones have the same configuration as the IP Communicators.

david.macias Thu, 02/28/2008 - 05:51
User Badges:
  • Blue, 1500 points or more

Start with comparing the IP Communicator configuration against the 7941. Make sure they are the same. Then I would make sure that the agent is logging in to the correct device, the 7941 in this case.


david

ageloskapousizis Thu, 02/28/2008 - 06:30
User Badges:

Thanks for the answer. I already checked this. The configuration of 7941 is exactly the same as the IP Communicator. For the other, I'm prety sure that I logging in the correct device, since I'm trying it by my self.

david.macias Thu, 02/28/2008 - 06:36
User Badges:
  • Blue, 1500 points or more

Where does the ICM script fail?


david

ageloskapousizis Thu, 02/28/2008 - 06:42
User Badges:

I created a very simple script in ICM, using one LAA node and one Skill Group, without queing. When an agent with IP Communicators are logged in, everything works. When, even one agent with 7941 logged in, the calls goes through the LAA node and goes to the Skill Group, but never reach the agent's phone and then the caller gets busy signal.

david.macias Thu, 02/28/2008 - 06:52
User Badges:
  • Blue, 1500 points or more

Check that you have a device target for the 7941.


david

Zin.Karzazi Thu, 02/28/2008 - 07:43
User Badges:
  • Silver, 250 points or more

The JTAPI user controls that device you are trying to reach? Go to the CCM Admin Page, desassociate and associate the Device to the JTAPI user. Also make sure that the user have the CTI enabled on the Callmanager Admin Page.

Abdulbaseer Mohammed Thu, 02/28/2008 - 13:01
User Badges:
  • Silver, 250 points or more

if you can share your script may be help it further.


do you get the ACD login screen under services for agent loging (sorry to ask if its too basic)


Thanks,

Baseer.

ageloskapousizis Mon, 03/03/2008 - 03:01
User Badges:

Hi,


I checked everything. All the devices are CTI enabled, none is primary extension number in the jtapi user and all of them are associated with the PG user into the CCM Application Users.


I realised that there are some specific devices that are not working independently of the device that are associated. What I mean is that, I had an IP Communicator with extension 94524 and was working properly. I had a 7941 with extension 94553 which was not working. I mean that when this phone was logging into the agent desktop everything was going wrong. What I tried was to change the extensions between each other. So, the IP Communicator had the extension 94553 and the 7941 the extension 94524. The result was that with the 7941 everything was working properly and with the IP Communicator everything was wrong. Of course I checked the device targets and both look the same.

o.soriano Fri, 04/25/2008 - 11:15
User Badges:

check the codec. the 7941 is using g.722 and the IPcom is using g.711

Riccardo Bua Mon, 04/28/2008 - 00:26
User Badges:
  • Cisco Employee,

The latest is indeed the source of the issue:


starting with CUCM 5.1, there is an Enterprise Parameter 'Advertise G.722 Codec', default to Enabled. This setting affects 7941, 7961, 7971, 7970 phones.


You need to disable it to run with G711 or set the phone in a G711 region.


Regards,


Riccardo


Actions

This Discussion