"sh arp" not working

Unanswered Question

Hi Team,

There is a switch-1 and from switch-1(C2950 Software (C2950-C3H2S-M), Version 12.0(5.3)WC(1)) one server is directly connected that have ip address 10.15.20.215.Once I ping the server ip address from switch-1. I got the reply.

But his ARP entry(IP address respect to Mac-address) does not show in the ARP table of the switch-1.On the other hand if I pinging the same server ip address from the other switch-2 (C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5.3)WC(1) it is reflecting the ARP entry in switch-2 ARP table. Please do the needful.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mark.j.hodge Thu, 02/28/2008 - 05:55

What IP address is set on the switches, is it on the same subnet as the server?

lamav Thu, 02/28/2008 - 06:21

Hi:

The 2950 is a layer 2 switch. Therefore, the forwarding table it keeps is populated by MAC addresses of directly connected machines. (show cam). You will not see arp entries on a layer 2 switch, except for the few entries that were learned by the management interface when telneting to another device.

HTH

Victor

Hi Mark,

You are correct . The above switch-1 is belong to the differnt network and we have put in the same networkand now the issue has been rectified.But i have one query more,"show mac-address-table" command does not working in the switch-1 while after put in the same segment but working in switch-2.Please do the needful.

Thanks for your great support.

Actions

This Discussion