WLC 4400 Zebra Wireless Printers invalid MIC errors

Unanswered Question

Hello,

I have 4404 WLC's running 4.0.217.0 and I am getting invalid MIC errors with new Zebra QL220 Plus printers using wpa/peap/tkip. All other clients work fine, just not these printers.

Error log:

[SECURITY]1x_eapkey.c 723: Received EAPOL-key M2 with invalid MIC from cckm mobile MAC ADDRESS

[SECURITY]1x_ptsm.c 391: MAX EAPOL-KEY M1 retransmissions reached for mobile MAC ADDRESS

According to Zebra's kb, changing the following settings is all that is required to get the printers to work. I did not have the same luck.

config advanced eap identity-request timeout 5

config advanced eap request-timout 5

The printers are running the latest software SHSTG10Z.

Any help is appreciated.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
plandobait Thu, 02/28/2008 - 09:29

I had QL420+ and wpa/psk/tkip and WLC's 4.0.217.0 - in this instance some of the QL420's would drop the last character of my key causing the MIC errors.

plandobait Thu, 02/28/2008 - 10:17

I should have typed more, but was rushing to get to a meeting. O.O

Are you using Label Vista for network setup or using parameter commands? I was using Label Vista - typing the key in ASCii.

What I meant by dropping is the Label Vista program would drop the last character if I copy/paste the ASCii key. If I hand typed the key in, it usually worked fine (providing I didn't fat finger it 3-4 times).

I did, however, have 5 or 6 out of 125 that I sent back because no matter what I did I ended up with MIC errors.

Hi,

We are using label vista which is a battle itself. We are using WPA1/PEAP/TKIP which requires user authentication so we dont have to worry about hex/ascii keys. We have tried different user accounts that are working on wireless devices right next to the printers and I don't think we are even getting to the point of authentication yet... I think its failing on setting up the 802.1x session with the cert keys. I will have the site try more printers, but the odds of the first 2 of 25 being bad aren't good.

Thanks for your help!

jamie

plandobait Thu, 02/28/2008 - 11:11

Label Vista is a trip...glad I don't have to use it anymore. :P

Sorry I couldn't help ya...was hoping hearing what I went through might spark something to check.

Maybe use the "debug lwapp events enable" command and "debug aaa all enable" commands to see what's going on once you power up the printer and it trys to authenticate.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode