Cannot configure ppp multilink group 1 on 2621

Answered Question
Feb 28th, 2008

I cannot enter this configuration for new multilink ppp T-1:

interf multlink 1

ip addr n.n.n.n n.n.n.n


ppp multlink group 1

int s0

ppp multlink group 1

The "multlink group 1" syntax is rejected, interface mult 1 is always down/down, and interface virtualaccess1 is created using fa0/0 unnumbered address. Not good!

hardware is 2621. IOS is 12.0(7)T.

Am I hitting an IOS version issue? If so, what version do I need? Anyone have a workaround without updating IOS?

Thank you

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 8 years 7 months ago

For that IOS version, the command is multilink-group, see:




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
cshirkoff Thu, 02/28/2008 - 10:03

I noticed multilink-group, but it doesn't use the mult 1 interface, rather creating int virtualaccess1. The problem with this is that it is picking up ip unnumbered from fa0/0.

How do I get it to use the specified IP address? I tried specifying an address in the virtual-template interface, but it always uses the IP from fa0/0.

Thank you

Edison Ortiz Thu, 02/28/2008 - 10:10

I never had any problem specifying an IP address under a virtual-template and not sure why it's inheriting the IP from Fa0/0 unless you are using the ip unnumbered command.

Care to post the config?

I can't help you much since I don't have that IOS around and it seems the configuration is a bit different for MLPPP, however I can refer you to the documentation site:




cshirkoff Thu, 02/28/2008 - 12:21

I removed the multilink commands from s0 (ok, actually s0/0), put them back in, and mult 1 is now up/up. Your info helped get this project back on track. Thank you!

For the record, config snippet to get this working is:

int s0/0

no ip addr

enc ppp

ppp multilink

multilink-group 1

int mult 1

ip addr n.n.n.n

ppp multilink

multilink-group 1


This Discussion