using static route with TE tunnel

Unanswered Question
Feb 28th, 2008

Hi Guys,

I am having some difficulty getting traffic into a TE tunnel using static routes.

the architecture is PE to PE via ethernet. i have a single route that comes in via a subinterface which is in a vrf, when i put in a static route i get no traffic coming back. if i use the auto-route announce feature everything works, but i only want this vrf to go down the tunnel. the config on one end is as follows:

interface Tunnel1

ip unnumbered Loopback0

mpls ip

tunnel destination x.x.x.x

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 1500

tunnel mpls traffic-eng path-option 10 dynamic


interface GigabitEthernet0/1.100

encapsulation dot1Q 100

ip vrf forwarding CCPUB

ip address 172.x.x.x


ip route Tunnel1

ip route Tunnel1

any suggestions?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Harold Ritter Fri, 03/07/2008 - 10:20


Are and VRF routes or BGP NH for the PEs advertising the VRF routes via BGP VPNv4? It should be the latter.

Hope this helps,

mheusing Wed, 03/12/2008 - 05:24

Hi Harold,

As the routes are /24 it will not work in either case.

If the routes are for BGP next hops they must be /32 and if they are within the VRF this will lead to packet leaking.

This means, the VPN label will not be attached and thus no connectivity within the VRF will be achieved.

This goes back to one of our discussions here in 2005:

Regards, Martin

Harold Ritter Thu, 03/13/2008 - 09:32


There is nothing that would prevent the BGP NH for VPNv4 routes to resolve via a /24 static route pointing at a tunnel interface, such as the ones posted by the original poster.

The fact that the BGP NH should be resolved via a /32 is rather a recommendation/best practices rather than a hard limitation.


mheusing Fri, 03/14/2008 - 03:41

Hi Harold,

this would only work, if the Loopback is configured as /24, otherwise the LIB would not contain a suitable entry and hence no label could be found. This is what I meant, but did not express to clearly.

Regards, Martin

Harold Ritter Fri, 03/14/2008 - 06:45


I was assuming TE LSP from ingress to egress PE. The LIB would not be used at all in this case.

You would still certainly need the loopback interface at the other end to be advertised as a /24 or greater for it to be overridden by the /24 static route pointing at the tunnel interface.


mheusing Fri, 03/14/2008 - 07:45

Hi Harold,

As "mpls ip" is configured on the tunnel interface would the LIB be in the picture then?

Regards, Martin


This Discussion