Catalyst 3750: Stack of 2 switch - Problem

Unanswered Question
Feb 29th, 2008

I have a stack of 2 catalyst 3750 and i have this situation:

#sh switch stack-ports

Switch # Port 1 Port 2

-------- ------ ------

1 Ok Down

2 Down Ok

#sh switch neighbors

Switch # Port 1 Port 2

-------- ------ ------

1 2 None

2 None 1

I would like to know if this situation is correct or not, I think is incorrect.

If it is incorrect, Can I change the stackwise interfaces?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jason.henderson Fri, 02/29/2008 - 13:16

You have sw1 stack-port 1 connected to sw2 stack-port 2.

Neighbors command shows that sw1 sees sw2 on sw1 stack-port 1, and vice-versa.

This is fine.

aijaz802 Fri, 02/29/2008 - 23:26


There is no problem....everything seems to be normal. Why do you thought its incorrect!!!

royalblues Sat, 03/01/2008 - 00:03


It would depend on whether you have connected both the stack cables between the switches.

As per your output there seems to be only one stack cable between the switches and is functioning normally

If you happen to connect the switches via both the stack ports, you would see something like below

MS_INDR_L3_SW1#sh switch stack-ports

Switch # Port 1 Port 2

-------- ------ ------

1 Ok Ok

2 Ok Ok


MS_INDR_L3_SW1#sh switch nei

MS_INDR_L3_SW1#sh switch neighbors

Switch # Port 1 Port 2

-------- ------ ------

1 2 2

2 1 1




Edison Ortiz Sat, 03/01/2008 - 16:11

Try reseating the connection. I know it's a pain to insert those cables and often the pins don't line-up properly.

If you reseat the cable and the problem persists, swap the cables and see if the problem follows the cable vs the stackports.

If the problem persists on the same stackports after changing the cable, you may have a faulty connector on either of the switches.




mirek.tichy_2 Wed, 03/05/2008 - 07:50

I have the same problem. I have tried lot of things allready - cable swapping, upgrade, downgrade. Problem is a half-duplex stackwise operation. It can be seen by the "show switch stack-ring speed". One pair of the ports are down and the others are on half-duplex.

mirek.tichy_2 Wed, 03/05/2008 - 09:07

I have just tried to connect third 3750 (older one). The result is - the third switch has always both ports up and the others have always down the second port. I tried to reconfigure the ring and the result is the same. Bad switches have always one port up and the second one down.


This Discussion