IP helper-address and MS DHCP Superscope

Unanswered Question
Feb 29th, 2008

I'm frustrated and thought I understood this.

I have a 3550 EMI switch in my home lab and I'm just trying to get simple DHCP to work with ip helper address for multiple vlans.

I have 3 VLANs on the 3550.

VLAN 1 - No Address

VLAN 69 - 192.168.69.11/24

VLAN 11 - 192.168.11.1/24

I have a MS 2003 Server and setup with a superscope to hand out address for these networks. The plan is to create a vlan for each one.

192.168.1.0/24

192.168.10.0/24

192.168.11.0/24

The server is in the 69 vlan on the switch. It has an ip of 192.168.69.202.

The problem is that regardless of the vlan I assign my laptop port too, I always get an IP address from the 192.168.1.0/24 pool.

So I am in the 11 vlan with the vlan assigned an address of 192.168.11.1. When I boot up my laptop I get a 192.168.1.x address.

WHY?!?!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10-11,69

!

!

!

no crypto isakmp enable

!

!

!

interface FastEthernet0/1

switchport mode dynamic desirable

!

interface FastEthernet0/2

switchport access vlan 69

switchport mode access

!

interface FastEthernet0/3

switchport mode dynamic desirable

!

interface FastEthernet0/4

switchport mode dynamic desirable

!

interface FastEthernet0/5

switchport mode dynamic desirable

!

interface FastEthernet0/6

switchport mode dynamic desirable

!

interface FastEthernet0/7

switchport mode dynamic desirable

!

interface FastEthernet0/8

switchport mode dynamic desirable

!

interface FastEthernet0/9

switchport mode dynamic desirable

!

interface FastEthernet0/10

switchport access vlan 11

switchport mode access

!

interface FastEthernet0/11

switchport mode dynamic desirable

!

interface FastEthernet0/12

switchport mode dynamic desirable

!

interface FastEthernet0/13

switchport mode dynamic desirable

!

interface FastEthernet0/14

switchport mode dynamic desirable

!

interface FastEthernet0/15

switchport mode dynamic desirable

!

interface FastEthernet0/16

switchport mode dynamic desirable

!

interface FastEthernet0/17

switchport mode dynamic desirable

!

interface FastEthernet0/18

switchport mode dynamic desirable

!

interface FastEthernet0/19

switchport mode dynamic desirable

!

interface FastEthernet0/20

switchport mode dynamic desirable

!

interface FastEthernet0/21

switchport mode dynamic desirable

!

interface FastEthernet0/22

switchport mode dynamic desirable

!

interface FastEthernet0/23

switchport mode dynamic desirable

!

interface FastEthernet0/24

switchport mode dynamic desirable

!

interface GigabitEthernet0/1

switchport mode dynamic desirable

!

interface GigabitEthernet0/2

switchport mode dynamic desirable

!

interface Vlan1

no ip address

shutdown

!

interface Vlan11

ip address 192.168.11.1 255.255.255.0

ip helper-address 192.168.69.202

!

interface Vlan69

ip address 192.168.69.11 255.255.255.0

!

ip classless

ip http server

ip http secure-server

!

!

!

control-plane

!

!

line con 0

line vty 0 4

login

line vty 5 15

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
miketta89 Fri, 02/29/2008 - 21:03

Fixed!

I posted too soon. The problem was on the Microsoft DHCP server. I ASSumed that a superscope was to create multiple scopes for different networks. Its not... ;)

I deleted it and created "normal" scopes and now it works as intended.

I'll become one of those Networker Engineerer thingies yet ;)

Edison Ortiz Fri, 02/29/2008 - 21:03

The switch configuration looks fine. The problem seems to be at the DHCP server side. Make sure when creating the scope, the router option (option 003) is 192.168.11.1 for the scope belonging to Vlan11.

HTH,

__

Edison.

Richard Burts Sat, 03/01/2008 - 10:08

Michael

Congratulations on figuring out the issue with the superscope (the name sure sounds like it would do what you wanted does it not?). And thanks for posting back to the forum to indicate that it was solved and what you did to solve it. It makes the forum more useful when people can read about an issue and can also read what the issue was and what was done to resolve the issue.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum as you work toward becoming a Network Engineer.

HTH

Rick

Actions

This Discussion