How to Configuration Cisco 3725 with NEC ASPILA EX

Answered Question
Mar 3rd, 2008
User Badges:

Dear all;

Now i have Cisco 3725 with 1-Port Channelized E1/T1/ISDN-PRI, i am connect to NEC ASPILA EX with PRI I/F (1PRIU-A1.

The controller link state up, but when clients dialin to RAS not have ring back or not connect to RAS.


anyone can help me?

Correct Answer by paolo bevilacqua about 9 years 4 months ago

No slips. Is the problem that the modem connection drops ? Which exact IOS are you running ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
paolo bevilacqua Mon, 03/03/2008 - 04:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Are these is isnd data calls? Take "debug isdn q931" with "term mon" to confirm.

Which exact hardware do you have in the 3725 ?

Sopholtum Mon, 03/03/2008 - 06:07
User Badges:

yes, ISDN data call. i'm to debug isdn not have anything alert to terminal, if i'm connected ISDN PRI direct (by pass NEC PBX) to Cisco i work fine.

paolo bevilacqua Mon, 03/03/2008 - 06:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What show isdn status tells you ?

You might need "isdn protocl-emulate network" when connecting via a PBX.

Sopholtum Mon, 03/03/2008 - 09:14
User Badges:

ISDN Controller status is up : that i'm show controller. ok form my picture ....

i'm have onece ISDN PRI form carrer provider, the last it direct to Cisco 3725 + RAS it work fine, and now the onece ISDN connect to NEC PBX and Onece ISDN PRI port of NEC PBX Connect Cisco 3725... it not work, ISDN status is up and when data calling not have respond from cisco. How i can troubbleshooting this solution? can or not?.


Help me Please.

=============================

RAS + Controller Config

=============================

isdn switch-type primary-net5

!

!

!

controller E1 2/0

line-termination 75-ohm

pri-group timeslots 1-31

!

!

interface Serial2/0:15

no ip address

ip nat inside

encapsulation ppp

ip policy route-map nachi-worm

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Group-Async1

description "Remote Connection for Analog Modem V92"

ip unnumbered FastEthernet0/0

ip access-group 122 in

ip nat inside

encapsulation ppp

ip route-cache policy

ip policy route-map nachi-worm

dialer in-band

dialer idle-timeout 512 either

dialer-group 1

async default routing

async mode dedicated

peer default ip address pool modem-dialin

no fair-queue

ppp authentication chap

group-range 33 62

hold-queue 10 in

!

interface Dialer1

description " Remote Connection for ISDN PRI No.=075205600 auto 100 Dialin"

ip unnumbered FastEthernet0/0

ip access-group 122 in

no ip redirects

no ip proxy-arp

ip nat inside

encapsulation ppp

ip route-cache policy

ip policy route-map nachi-worm

load-interval 30

dialer-group 1

peer default ip address pool modem-dialin

no fair-queue

no cdp enable

ppp authentication chap pap dialin

ppp multilink

!



Attachment: 
paolo bevilacqua Mon, 03/03/2008 - 12:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, as mentioned before when connecting to a PBX usually you need "isdn protocol-emulate network".

Then your show isdn status should show multiframe established, please copy it here.

Sopholtum Mon, 03/03/2008 - 19:41
User Badges:

ok, i will be onsite and keep messeges to you again. wait please.

Sopholtum Tue, 03/04/2008 - 21:42
User Badges:

Hi,

After i'am connected to PBX ISDN Status is

---------------------------

SSJTrang-ACC-Server#show isdn stat

Global ISDN Switchtype = primary-net5

ISDN Serial2/0:15 interface

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMENT

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x7FFF7FFF

Number of L2 Discards = 0, L2 Session ID = 23

Total Allocated ISDN CCBs = 0

------------------------------------------

SSJTrang-ACC-Server#show controllers e1 2/0 brief

E1 2/0 is up.

Applique type is Channelized E1 - unbalanced

No alarms detected.

alarm-trigger is not set

Framing is CRC4, Line Code is HDB3, Clock Source is Line.

Module type is Channelized E1/T1 PRI

Version info Firmware: 0000001D, FPGA: 0

Hardware revision is 0.0 , Software revision is 29

Protocol revision is 1

number of CLI resets is 0

receive remote alarm : 0,

transmit remote alarm : 0,

receive AIS alarm : 0,

transmit AIS alarm : 0,

loss of frame : 4,

loss of signal : 4,

Loopback test : 0,

transmit AIS in TS 16 : 0,

receive LOMF alarm : 0,

transmit LOMF alarm : 0,

MIB data updated every 10 seconds.

Data in current interval (297 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

35121 Line Code Violations, 2 Path Code Violations,

0 Slip Secs, 2 Fr Loss Secs, 4 Line Err Secs, 0 Degraded Mins,

4 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 6074 Unavail Secs

----------------------------------------------

paolo bevilacqua Wed, 03/05/2008 - 02:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, as mentioned twice before, you need to configure "isdn protocol-emulate network" under interface, else the isdn link will never come up. Also, the clock source should be internal.


Hope this helps, please rate post if it does!

Sopholtum Thu, 03/06/2008 - 08:38
User Badges:

Hi;

i'am config cisco as you recommended is "isdn protocol-emulate network" and "clock source should be internal". After the remote computer call to RAS it have modem signal and then connected, next time it disconnect. can i change some parameter for this problem or what i'am wrong?. I post config, status, and debug message for you. Help me..


===== show isdn status ===========

#show isdn status

Global ISDN Switchtype = primary-net5

ISDN Serial2/0:15 interface

******* Network side configuration *******

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0xFFFF7FFF

Number of L2 Discards = 0, L2 Session ID = 0

Total Allocated ISDN CCBs = 0


=============== sh controllers e1 2/0 brief ========

#sh controllers e1 2/0 brief

E1 2/0 is up.

Applique type is Channelized E1 - unbalanced

No alarms detected.

alarm-trigger is not set

Framing is CRC4, Line Code is HDB3, Clock Source is Internal.

Module type is Channelized E1/T1 PRI

Version info Firmware: 0000001D, FPGA: 0

Hardware revision is 0.0 , Software revision is 29

Protocol revision is 1

number of CLI resets is 0

receive remote alarm : 0,

transmit remote alarm : 0,

receive AIS alarm : 0,

transmit AIS alarm : 0,

loss of frame : 1,

loss of signal : 1,

Loopback test : 0,

transmit AIS in TS 16 : 0,

receive LOMF alarm : 0,

transmit LOMF alarm : 0,


========== Interface config.=============

!

controller E1 2/0

clock source internal

line-termination 75-ohm

pri-group timeslots 1-31

!

!

interface Serial2/0:15

no ip address

ip nat inside

encapsulation ppp

ip policy route-map nachi-worm

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-net5

isdn protocol-emulate network

isdn incoming-voice modem

no fair-queue

no cdp enable

!

=================Debug Message when call to RAS ===========================

Mar 6 22:40:29 BANGKOK: ISDN Se2/0:15 Q931: RX <- SETUP pd = 8 callref = 0x000B

Bearer Capability i = 0x8090A3

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9838B

Exclusive, Channel 11

Calling Party Number i = 0x0081, N/A

Plan:Unknown, Type:Unknown

Called Party Number i = 0x81, '075205600'

Plan:ISDN, Type:Unknown

Low Layer Compat i = 0x8090A3

High Layer Compat i = 0x9181

Mar 6 22:40:29 BANGKOK: ISDN Se2/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x800B

Channel ID i = 0xA9838B

Exclusive, Channel 11

Mar 6 22:40:29 BANGKOK: ISDN Se2/0:15 Q931: TX -> ALERTING pd = 8 callref = 0x800B

Mar 6 22:40:29 BANGKOK: ISDN Se2/0:15 Q931: TX -> CONNECT pd = 8 callref = 0x800B

Mar 6 22:40:35 BANGKOK: %ISDN-6-CONNECT: Interface Serial2/0:10 is now connected to unknown unknown

Mar 6 22:40:46 BANGKOK: %ISDN-6-DISCONNECT: Interface Serial2/0:10 disconnected from unknown , call lasted 17 seconds

Mar 6 22:40:46 BANGKOK: ISDN Se2/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x800B

Cause i = 0x8290 - Normal call clearing

Mar 6 22:40:47 BANGKOK: ISDN Se2/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x000B

Mar 6 22:40:47 BANGKOK: ISDN Se2/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x800B

==============================================


paolo bevilacqua Thu, 03/06/2008 - 08:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, please send the complete "show controllers e1", you may be getting slips due to lack not network-clock-participate commands.

Sopholtum Thu, 03/06/2008 - 09:02
User Badges:

The complete "show controllers e1",


=============================================

#show controllers e1 2/0

E1 2/0 is up.

Applique type is Channelized E1 - unbalanced

No alarms detected.

alarm-trigger is not set

Framing is CRC4, Line Code is HDB3, Clock Source is Internal.

Module type is Channelized E1/T1 PRI

Version info Firmware: 0000001D, FPGA: 0

Hardware revision is 0.0 , Software revision is 29

Protocol revision is 1

number of CLI resets is 0

receive remote alarm : 0,

transmit remote alarm : 0,

receive AIS alarm : 0,

transmit AIS alarm : 0,

loss of frame : 1,

loss of signal : 1,

Loopback test : 0,

transmit AIS in TS 16 : 0,

receive LOMF alarm : 0,

transmit LOMF alarm : 0,

MIB data updated every 10 seconds.

Data in current interval (852 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 1:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 2:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 3:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 4:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 5:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 6:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 7:

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in Interval 8:

8191 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 166 Unavail Secs

Total Data (last 8 15 minute intervals):

8191 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 166 Unavail Secs

=============================================

Correct Answer
paolo bevilacqua Thu, 03/06/2008 - 12:50
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

No slips. Is the problem that the modem connection drops ? Which exact IOS are you running ?

Sopholtum Thu, 03/06/2008 - 18:07
User Badges:

IOS is ....

3700 Software (C3725-IPBASE-M), Version 12.3(9e), RELEASE SOFTWARE (fc1)


Sopholtum Fri, 03/07/2008 - 01:02
User Badges:

yes, modem connection drop. IOS is 3700 Software (C3725-IPBASE-M), Version 12.3(9e), RELEASE SOFTWARE (fc1)

paolo bevilacqua Fri, 03/07/2008 - 01:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try upgrading to latest 12.3 that is (21) or so.

Sopholtum Fri, 03/07/2008 - 02:15
User Badges:

i'm not have one more of IOS versions. but i have message post to you two condition are "Remote Computer call form local number of PBX" it work fine, but and "Remote Computer form external" when modem stat "TRAINUP" it disconnect. flowing message ..


====== Remote Computer call form local number of PBX ===============

Mar 7 14:06:37 BANGKOK: ISDN Se2/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0005

Bearer Capability i = 0x9090A3

Standard = CCITT

Transer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9838B

Exclusive, Channel 11

Progress Ind i = 0x8083 - Origination address is non-ISDN

Calling Party Number i = 0x0081, N/A

Plan:Unknown, Type:Unknown

Called Party Number i = 0x81, '075205600'

Plan:ISDN, Type:Unknown

Low Layer Compat i = 0x9090A3

Mar 7 14:06:37 BANGKOK: Modem 1/9 Mica: configured for Answer mode, with Null signaling, 0x0 tone detection.

Mar 7 14:06:37 BANGKOK: ISDN Se2/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8005

Channel ID i = 0xA9838B

Exclusive, Channel 11

Mar 7 14:06:37 BANGKOK: ISDN Se2/0:15 Q931: TX -> ALERTING pd = 8 callref = 0x8005

Mar 7 14:06:37 BANGKOK: ISDN Se2/0:15 Q931: TX -> CONNECT pd = 8 callref = 0x8005

Mar 7 14:06:37 BANGKOK: Modem 1/9 Mica: in modem state CALL_SETUP

Mar 7 14:06:38 BANGKOK: Modem 1/9 Mica: in modem state CONNECT

Mar 7 14:06:38 BANGKOK: Modem 1/9 Mica: in modem state V8BIS_EXCHANGE

Mar 7 14:06:40 BANGKOK: Modem 1/9 Mica: in modem state QUICK_CONNECT

Mar 7 14:06:42 BANGKOK: Modem 1/9 Mica: in modem state RANGING

Mar 7 14:06:43 BANGKOK: %ISDN-6-CONNECT: Interface Serial2/0:10 is now connected to unknown unknown

Mar 7 14:06:45 BANGKOK: Modem 1/9 Mica: in modem state HALF_DUPLEX_TRAIN

Mar 7 14:07:07 BANGKOK: Modem 1/9 Mica: in modem state TRAINUP

Mar 7 14:07:09 BANGKOK: Modem 1/9 Mica: in modem state EC_NEGOTIATING

Mar 7 14:07:09 BANGKOK: Modem 1/9 Mica: in modem state STEADY

Mar 7 14:07:09 BANGKOK: Modem 1/9 Mica: received ConnectInfo

Mar 7 14:07:09 BANGKOK: Modem 1/9 Mica: CONNECT at 31200/28800 (Tx/Rx), V34+, LAPM, V44

Mar 7 14:07:10 BANGKOK: TTY42: DSR came up

Mar 7 14:07:10 BANGKOK: TTY42: no timer type 1 to destroy

Mar 7 14:07:10 BANGKOK: TTY42: no timer type 0 to destroy

Mar 7 14:07:10 BANGKOK: TTY42: no timer type 2 to destroy

Mar 7 14:07:10 BANGKOK: tty42: Modem: IDLE->(unknown)

Mar 7 14:07:11 BANGKOK: Modem 1/9 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0

Mar 7 14:07:11 BANGKOK: %LINK-3-UPDOWN: Interface Async42, changed state to up

Mar 7 14:07:12 BANGKOK: Modem 1/9 Mica: PPP escape_map: Tx map = 0, Rx map = 0

Mar 7 14:07:12 BANGKOK: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async42, changed state to up

Mar 7 14:07:23 BANGKOK: Modem 1/9 Mica: in modem state SS_RETRAINING

Mar 7 14:07:32 BANGKOK: Modem 1/9 Mica: in modem state STEADY

Mar 7 14:07:32 BANGKOK: Modem 1/9 Mica: Retrained to 31200/28800 (Tx/Rx)

Mar 7 14:07:42 BANGKOK: Modem 1/9 Mica: in modem state SS_RETRAINING


===== > next post for Remote Computer form external message.

Sopholtum Fri, 03/07/2008 - 02:19
User Badges:

========= Remote Computer form external message ===========

Mar 7 14:29:21 BANGKOK: ISDN Se2/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0007

Bearer Capability i = 0x8090A3

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9838E

Exclusive, Channel 14

Calling Party Number i = 0x0081, N/A

Plan:Unknown, Type:Unknown

Called Party Number i = 0x81, '075205600'

Plan:ISDN, Type:Unknown

Low Layer Compat i = 0x8090A3

High Layer Compat i = 0x9181

Mar 7 14:29:21 BANGKOK: Modem 1/11 Mica: configured for Answer mode, with Null signaling, 0x0 tone detection.

Mar 7 14:29:21 BANGKOK: ISDN Se2/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8007

Channel ID i = 0xA9838E

Exclusive, Channel 14

Mar 7 14:29:21 BANGKOK: ISDN Se2/0:15 Q931: TX -> ALERTING pd = 8 callref = 0x8007

Mar 7 14:29:21 BANGKOK: ISDN Se2/0:15 Q931: TX -> CONNECT pd = 8 callref = 0x8007

Mar 7 14:29:21 BANGKOK: Modem 1/11 Mica: in modem state CALL_SETUP

Mar 7 14:29:22 BANGKOK: Modem 1/11 Mica: in modem state CONNECT

Mar 7 14:29:22 BANGKOK: Modem 1/11 Mica: in modem state V8BIS_EXCHANGE

Mar 7 14:29:26 BANGKOK: Modem 1/11 Mica: in modem state LINK

Mar 7 14:29:27 BANGKOK: %ISDN-6-CONNECT: Interface Serial2/0:13 is now connected to unknown unknown

Mar 7 14:29:31 BANGKOK: Modem 1/11 Mica: in modem state TRAINUP

Mar 7 14:29:33 BANGKOK: ISDN Se2/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x0007

Cause i = 0x8090 - Normal call clearing

Mar 7 14:29:33 BANGKOK: %ISDN-6-DISCONNECT: Interface Serial2/0:13 disconnected from unknown , call lasted 12 seconds

Mar 7 14:29:33 BANGKOK: ISDN Se2/0:15 Q931: TX -> RELEASE pd = 8 callref = 0x8007

Mar 7 14:29:33 BANGKOK: Modem 1/11 Mica: in modem state TERMINATING

Mar 7 14:29:33 BANGKOK: Modem 1/11 Mica: received TerminateInfo

Mar 7 14:29:33 BANGKOK: ISDN Se2/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x0007

Mar 7 14:29:33 BANGKOK: Modem 1/11 Mica: in modem state IDLE

Mar 7 14:29:33 BANGKOK: Modem 1/11 Mica: DISCONNECT after 00:00:11, due to reason (0x7F06) DS1 network disconnect (no carrier)

=====================================

Actions

This Discussion